New Mac Mini still doesn't play 1080p?

Discussion in 'Mac mini' started by Dae, Aug 12, 2010.

  1. Dae macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #1
    Hello,
    I bought a new aluminium Mac Mini hoping to use it with my TV to play fullHD videos. What lured me is the new HDMI slot and upgraded videocard.

    But when I uploaded my movies, it turned out that the playback is stuttering every 3-4 seconds (sometimes less often, i.e 10 seconds) regardless of the movie and video player used. I tried VLC, Plex, Perian+Quicktime, MPlayer OS X Extended. Even 720p videos stutter a bit.

    Basically the performance is pretty much the same as on my 2007 MBP. I was hoping such task wouldn't be as hard for the modern hardware (or what Apple thinks is modern, *ahem*), but it seems that I was wrong.

    What should I do? Return it to the store? Give Windows a go? Upgrade the RAM to 4GB?

    Thank you.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Are those Blu-Ray rips? What are you using for audio? The biggest problem I've heard is the audio as if it has to be decoded, it hogs the CPU resulting worse video playback. I guess others can help you more, especially Cave Man
     
  3. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #3
    Yep, most of them are blu-ray rips and some are hd-dvd rips.

    Sound is in AC3 5.1 if that's what you mean.
     
  4. MikeinJapan macrumors regular

    Joined:
    Apr 23, 2010
    Location:
    Tokyo
    #4
    My mini is a 09 model with 2GB RAM and as no problems at all with 1080p with surround sound via optical cable to an AV amp. Somethind seems strange!
     
  5. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #5
    you need to specify bitrate, codec, file type, framerate, container, cpu utilization stats, etc. we can't help you if you don't provide details. upload a sample of the problematic file for others to test it on their system.

    personally i haven't had a single problem playing 1080p h.264 files with reasonable bitrates (< 20Mbps) and AC3 or DTS. my 4 yeard old macbook pro could do this as well, so really the 2010mini shouldn't have any problems (at least in processing power).
     
  6. Bitgod macrumors regular

    Bitgod

    Joined:
    Oct 25, 2003
    #6
    You mentioned you're using this with a TV, does it do the same thing connected to a display, if you have the ability to connect via HDMI.

    I tested out my mini with my display that has a HDMI port and it played back fine. So I connected it to my TV and found that when I played back 1080p, it would get some stuttering in the video, but non-1080p played back fine.

    Found out the fix for me was that I have a Samsung 120Hz LCD, one of their first models I think, and if I have their 120Hz feature turned on, it causes the stuttering. I thought I had had the feature turned off, because it has other issues and I'd given up on it, but I had apparently left it on "low". Turning it off cleared up the stuttering.

    I had also come across another suggestion that was basically something like something wasn't being able to handle the refresh rate/data rate, something like that, and to turn down the refresh rate just a touch and that helped some people. I think it helped me before I figured out the 120Hz was still on.
     
  7. Cave Man macrumors 604

    Cave Man

    #7
    Yup, this sounds like a refresh rate issue with the display. Notorious problem.
     
  8. Dae thread starter macrumors regular

    Dae

    Joined:
    Apr 30, 2009
    #8
    Ha, it's vice versa for me it seems.

    I enabled "MotionFlow" feature and playback became very smooth.
     
  9. mangrove macrumors 6502

    Joined:
    Jul 10, 2010
    Location:
    FL, USA
    #9
    Plugged mine into my HDTV via HDMI, never had a problem. The over/under scan in sys pref>display was all I played with.

    Netflix movies are really great for $8.99/mo. We stream 1-2 movies every day. Can get better than that to me!

    The 2010 Mini is every thing and more to me.

    Most threads seem to point to the TV/monitor as the culprit not the Mini.:cool:
     
  10. painejake macrumors newbie

    painejake

    Joined:
    Aug 11, 2010
    Location:
    Birmingham, UK
    #10
    Try playing after, in VLC, going to

    Preferences > Input and Codecs

    and change Skip H.264 in-loop deblocking filter to all.


    Edit: I missed your post there ;) This can also help with these issues or did on the older Minis.
     
  11. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #11
    the only thing this will do is make your h.264 pic blocky. the c2d in the mini can play 1080p just fine without having to skip the loop filter. i realize a lot of peoples/sites recommend skipping the loop filter, but it's just flat out wrong.
     
  12. Giuly macrumors 68040

    Giuly

    #12
    I guess you just want a pair of these, or a pair of those.

    The 2x1GB the stock Mini comes with is not enough. Have a look at the System Activity monitor to see where the problem lyes.

    I play 1080p and even 1080i w/ deinterlacing without any problem on my 2.66GHz Mini w/ 8GB RAM.
     
  13. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #13
    my base mini with 2gb of ram plays 1080p just fine. what does ram have anything to do with picture quality anyway?
     
  14. Giuly macrumors 68040

    Giuly

    #14
    Nothing with the image quality, but if the RAM is all used up, the image may start to stutter - which is the problem of the OP. Try opening up Safari with 2GB of RAM while watching 1080p, not nice either. Safari + 1080p takes up about 2,5GB of RAM here, with flash killed.

    In my old linux machine, this stuttering with 1080p was caused due to old and slow hard drives, i.e. The Minis hard drive should be fast enough to play untouched BluRays, though.
     
  15. iBunny macrumors 65816

    Joined:
    Apr 15, 2004
    #15
    My HD rips were stuttering on my TV until I changed the pulldown settings.

    I changed my Bravia's settings to operate at 120Hz vice 60Hz (since 120 is divisible by 24Hz (Blu-Ray), where as 60Hz is not.) And problem solved <3
     
  16. glitch44 macrumors 65816

    Joined:
    Feb 28, 2006
    #16
    Does anyone even read the messages before they reply?

    The OP fixed the problem in reply #8.
     

Share This Page