New Mac Mini - WIFI Issues - Pls Help!

Discussion in 'OS X Yosemite (10.10)' started by C158, Feb 14, 2015.

  1. C158 macrumors newbie

    Joined:
    Jan 31, 2015
    #1
    Hello,

    I just a got a new mac mini and the wifi keeps dropping.

    I got everything set up and all was fine (10.10.2). Then about an hour in things got a bit buggy the Bluetooth tweaked (wireless keyboard, mouse) and the wifi dropped. Rebooted computer and the wifi was still not working. Then a couple minutes later it picked right back up. Then dropped again, which led me to hit the web searching for answers via my 2013 MBA running 10.10.2 whos wifi has been just fine.

    Things that may help those helping me:

    - We have a old century link router - it sucks, but should not be the prob. We have 3 newer MBAs that are using it all on 10.10.2 with no probs. Along wit misc other devices.

    -To add a new variable I used my LG G3 as a wifi hot spot running 4g LTE. The problems were consistent between the two.

    - I hard reset the computer

    -I reset the keychain

    -I followed various advice that I found when searching the problem on the web which included the above along with resetting the DHCS? subscription (not the right word), along with a few other things.

    - It tried to do a fresh install, but with no wifi and no ability to hard wire in, I could not.

    -Everytime the bars went gray, the computer would still "see" my G3 and the house router, but when you clicked on one of them it would come up with a message saying it could not connect.

    So I gave up, went to sleep, woke up and turned it on. Wifi worked. Then it was VERY slow. The wifi bars were black, but loading a page was impossible. I loaded the same page on my mba with no prob using the same wifi.

    I did a quick search online again and this time found on apples own site that wifi 3.0 can cause wifi problems?? Well, I have a Sibernet 3.0 4 port plugged into the back so I unplugged it, closed the internet reopened and went to the same website and youtube, both loaded just fine. Was that the prob??? Who knows....sigh I had to go to work so that's where I left it.

    Any other ideas? This is extremely frustrating.

    Thank you
     
  2. Richdmoore macrumors 65816

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #2
    So your wifi will work unless you plug in the USB hub, correct?

    First, make sure it works without the hub or cable attached. Once you narrow it down, I would first try to replace the cable between the hub and the computer.

    It could be the hub maker provided a cheap USB cable with minimal or no shielding, which is causing interference. The next step would be to replace the whole USB 3 hub with another brand.

    Wifi issues can be a pain to diagnose. My brother went thru 3 routers (even 2 apple airports) without success. By accident he unplugged an old USB dongle on another PC, and all the issues when away. It turned out the old POS wifi dongle was actually causing interference with all the other computers wifi in the house!
     
  3. C158 thread starter macrumors newbie

    Joined:
    Jan 31, 2015
    #3
  4. C158 thread starter macrumors newbie

    Joined:
    Jan 31, 2015
    #4
    Ok, got home from work....

    I plugged the hub I linked into my mba and after maybe two minutes it too lost wifi.

    So its the hub.

    So if anyone has wifi problems check your usb 3.0 if you have any plugged in.


    This is a cheap unit so it likely is not shielded very well.
     
  5. Richdmoore macrumors 65816

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #5

Share This Page