New Mac Owner - Need Web Design Help

Discussion in 'Web Design and Development' started by Charlie-Burt, Jul 15, 2010.

  1. Charlie-Burt macrumors newbie

    Joined:
    Jul 14, 2010
    #1
    Hi, I just bought an imac. My wife has a few sites she works on. She uses Arachnophilia HTML editor and has a site template with all her support files and pages contained within.

    Coming from windows, Arach was in "program files" and she just dragged and dropped her site template into the Arach folder in "Program files"..worked like a charm.

    Just got the imac yesterday. I downloaded Arach (for mac) on her imac, made a copy of her template files and put them on the imac.

    To make a long story longer...Arach and template files are in "documents" on the imac. I have to open Arach and search for the template files to add them to Arach (they were automatically there in windows when she dropped them into Arach program folder)

    now for the problem...when I open a page to edit in Arach, I get an error when I try to save changes..saying...Unable to write file
    "user/desktop/new-sbisite2/index.html
    java.10.FileNotFoundException;(permission denied)

    or

    "these file types cannot be edited"

    Can anyone please tell me whats going on? I've dragged and dropped Arach and template into "Application" on imac...I put them both on the desktop, put them back in "documents" I just can't get them to mate up, merge.

    I don't understand why these file types can't be edited and saved.

    Thanks for ANY help...
    Charlie-Burt
     
  2. eponym macrumors 6502

    Joined:
    Jul 2, 2010
    #2
    Check the files themselves. It's quite likely the permissions on the file(s) were locked during the copy from Windows to Mac OS X.

    Right click (or control + click) on a file (or better yet, the parent folder of the files) and select "Get Info".

    At the bottom you'll see the user permissions. And towards the top, under the "General" section you'll see a checkbox labeled "Locked". Have a look to make sure those are okay.
     
  3. Charlie-Burt thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #3
    I checked and the locked box is not checked. I noticed the default "open" is set to Safari, Would changing this make any difference or is this just for preview? Sharing and Permissions are :read only

    Do you think it could be the HTML editor my wife is using that's the problem?

    Thanks a bunch for replying.
     
  4. Dunmail macrumors regular

    Joined:
    Mar 27, 2009
    Location:
    Skipton, UK
    #4
    The folder and the files it contains should be marked as "read and write", use the spinner next to the text in the Get Info dialog to change it to this.
     
  5. Charlie-Burt thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #5
    You are a life saver:D. I was about to pull my hair out. Now one last (well maybe not last) question. There's over 300 pages...am I (gulp) gonna have to change each page manually to read and write or is there a easier way to apply this change to the entire folder of pages?

    Again...Thank You So Much!!!

    Charlie Burt
     
  6. Dunmail macrumors regular

    Joined:
    Mar 27, 2009
    Location:
    Skipton, UK
    #6
    how confident are you with the command line? If you don't mind getting your mitts dirty then open the terminal (it's in applications, utilities) then move to the parent folder of the folder holding the files using the cd command. Then do:

    chmod -Rf u+w folder_name

    The "-R" means recurse down the directory structure
    "f" means force, i.e. don't ask to confirm the action
    u+w means add write permissions to the user(i.e. you)
     
  7. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #7
    No, you can select all the files and press option+apple+I to edit the info for all at once, or do apple+I on the enclosing folder, edit it there, and choose 'apply to enclosed items'.
     
  8. Charlie-Burt thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #8
    Thanks so much...you folks are swell!

    First time mac owner...(actually just got my imac yesterday) feel like a stranger in a strange land...but the fruit is sweet...
     
  9. Dunmail macrumors regular

    Joined:
    Mar 27, 2009
    Location:
    Skipton, UK
    #9
    Now that I didn't know - I reckoned there must have been a graphical alternative to the command line but since I always have a terminal open (force of habit on Unix/Linux systems) it would have taken me longer to look up how to do it the graphical way than simply type the command itself. However, I have just tried both ways and the first method has the options to change permissions greyed out - it might be a global setting on my system preventing this.
     

Share This Page