New Mac Pro - clock "always" 2-minutes fast?

Discussion in 'Mac Pro' started by michael_aos, May 19, 2014.

  1. michael_aos macrumors 6502

    Joined:
    Jan 26, 2004
    #1
    Every so often, I'll notice the clock on my Mac Pro 6,1 is about 2-minutes fast.

    If I navigate to "Date & Time" under System Preferences, it automatically (re)sets itself via NTP.

    Anyone else noticed this?

    I don't think it's necessarily a Mavericks issue, as I've never noticed it on my Mac Mini or MacBook Air.
    --
     
  2. slask macrumors newbie

    Joined:
    Feb 23, 2014
    #2
    Yeah, it is a known bug that apple has no interest in squashing.

    You would think a computer should at least keep time, right?

    Fix:

    sudo crontab -e

    Then paste this and save:

    */30 * * * * killall ntpd > /dev/null
     
  3. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #3
    In Terminal.app, what is the output of "ntpdc -s" when the time is wrong?

    For example...

    Code:
    $ ntpdc -s
         remote           local      st poll reach  delay   offset    disp
    =======================================================================
    *time4.apple.com 192.168.1.7      2  512  377 0.02336 -0.066405 0.30530
     
  4. michael_aos thread starter macrumors 6502

    Joined:
    Jan 26, 2004
    #4
    $ date ; ntpdc -s
    Tue May 20 11:24:48 MDT 2014
    remote local st poll reach delay offset disp
    =======================================================================
    time6-st1.apple 192.168.0.175 2 512 377 0.06783 -18.01520 0.33772

    --

    After visiting the Date & Time preferences:

    $ date ; ntpdc -s
    Tue May 20 11:25:27 MDT 2014
    remote local st poll reach delay offset disp
    =======================================================================
    time3-nwk.apple 192.168.0.175 16 64 0 0.00000 0.000000 4.00000
     
  5. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #5
    Ok, this is working. Stratum of 2 is good and expected, your lock was off by 18 seconds at this time.

    This one is not working, stratum of 16 means that the indicated time server cannot be synchronized with for some reason. Since you now only have a single NTP source and it can't be synced with your clock is going to skew without any way for ntpd to keep it in sync.

    time3-nwk.apple.com does work fine for me, so there may be something blocking it for you.

    Code:
    $ ntpdate -q time3-nwk.apple.com
    server 17.151.16.38, stratum 2, offset -0.002503, delay 0.04767
    20 May 10:43:38 ntpdate[92265]: adjust time server 17.151.16.38 offset -0.002503 sec
    You could also try using a different NTP server in the Date & Time prefs. You can type in a different NTP server into the drop down, you're not limited to just Apple's. Try using "time.nist.gov" and see if that works more consistently.
     
  6. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #7

Share This Page