New Mac Pro shuts down during sleep

Discussion in 'Mac Pro' started by Pagemakers, Jul 28, 2014.

  1. Pagemakers macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #1
    My Pro 2013 sometimes shuts down during sleep. Nothing will wake the machine and it it not accessible by another other computer on the network. It has to be manually re-started using the button on the back of the computer. There are no error messages on re-start.

    I have reset the SMC and PRAM but it makes no difference.

    Any ideas?
     
  2. z06gal macrumors 6502

    Joined:
    Aug 30, 2011
    #2
    I am having the same issue and nothing I have tried has worked. I guess I will have to shut it down at night until there is a fix. So frustrating :eek:
     
  3. omvs macrumors 6502

    Joined:
    May 15, 2011
    #3
    Perhaps a bug in the deepsleep mode?

    Maybe try:
    sudo pmset -a hibernatemode 0
    sudo pmset -a autopoweroff 0

    My cMP doesn't support this i believe, so can't test for you. But I believe I disabled in my imac at one point because it took too long to restart...
     
  4. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #4
    omvs before I try this, what are your commands doing and how can I set them back to their defaults states?
     
  5. omvs macrumors 6502

    Joined:
    May 15, 2011
    #5
    They're modifying the power management settings - there is a lot more settings than are exposed than in the system preferences.

    You should be able to get current settings with something like:
    pmset -a -g

    and for some documentation
    man pmset


    All said, I'm not that much an expert using pmset, and if you're not comfortable using terminal commands might not be the right solution. The $ version of Trim Enabler exposed the deep sleep (hibernate) in a gui - not sure of what other tools can modify autopoweroff, which might be what you really need.
     
  6. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #6
    We have 2 Mac Pros here. I ran the pmset -a -g command and below are the results from both Macs. The 2nd one is the one with the problem.


    Paul Mac Pro:~ Paul$ pmset -a -g
    Active Profiles:
    AC Power -1*
    Currently in use:
    standby 1
    Sleep On Power Button 1
    womp 1
    autorestart 0
    hibernatefile /var/vm/sleepimage
    darkwakes 1
    gpuswitch 2
    networkoversleep 0
    disksleep 10
    sleep 1
    autopoweroffdelay 14400
    hibernatemode 0
    autopoweroff 1
    ttyskeepawake 1
    displaysleep 25
    standbydelay 10800

    Paresh Mac Pro:~ Paresh$ pmset -a -g
    Active Profiles:
    AC Power 2*
    Currently in use:
    standby 1
    Sleep On Power Button 1
    womp 1
    autorestart 0
    hibernatefile /var/vm/sleepimage
    gpuswitch 2
    darkwakes 1
    networkoversleep 0
    disksleep 10
    sleep 1 (sleep prevented by AddressBookSour)
    autopoweroffdelay 14400
    hibernatemode 0
    autopoweroff 1
    ttyskeepawake 1
    displaysleep 10
    standbydelay 10800
     
  7. omvs macrumors 6502

    Joined:
    May 15, 2011
    #7
    interesting that the AC power profile gives different numbers. My work machine reports 2 as well like your 'bad' machine, but i'm not sure what to make of that... Also interesting that something is preventing sleep, but again.. ??


    I'd still be tempted to set the autopoweroff to 0. You might have a different underlying problem, but that might fix the symptom...
    pmset -a autopoweroff 0
     
  8. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #8
    OK I’ll give it a try. I guess I can always set pmset -a autopoweroff 1 if it fails?

    ----------

    This was the result. autopoweroff is now showing 0

    Paresh Mac Pro:~ Paresh$ sudo pmset -a autopoweroff 0
    Password:
    Warning: Idle sleep timings for "AC Power" may not behave as expected.
    - Display sleep should have a lower timeout than system sleep.
     
  9. omvs macrumors 6502

    Joined:
    May 15, 2011
    #9
    Technically the -a flag is affecting all power profiles - if you want a lighter touch you might want -c (wall power) or -u (ups) - maybe your two machines are on different profiles because one knows a UPS is connected? The other profile -b (battery) i think is for when the UPS is supplying current rather than wall.

    Actually, this is interesting - my cMP at home shows this, suggesting that -1 might be when the computer things its running off the battery...? My work machine with no ups just shows AC Power 2*

    Is it possible you swapped the settings for your two machines? If the machine things its running off the ups battery, that might explain why its shutting down...

    (home cMP off UPS)
    dhdesktophome:~ dhartman$ pmset -a -g
    Active Profiles:
    UPS Power -1
    AC Power 2*
    Currently in use:
    hibernatemode 0
    womp 1
    networkoversleep 0
    sleep 10 (sleep prevented by screensharingd)
    Sleep On Power Button 1
    ttyskeepawake 1
    hibernatefile /var/vm/sleepimage
    autorestart 0
    disksleep 10
    displaysleep 10

    Work imac w/o UPS
    Dans-iMac:~ dhartman$ pmset -a -g
    Active Profiles:
    AC Power 2*
    Currently in use:
    hibernatemode 0
    halfdim 1
    womp 1
    networkoversleep 0
    sleep 10 (sleep prevented by iTunes, coreaudiod)
    Sleep On Power Button 1
    ttyskeepawake 1
    hibernatefile /var/vm/sleepimage
    autorestart 0
    disksleep 10
    displaysleep 10
     
  10. Pagemakers, Jul 28, 2014
    Last edited: Jul 28, 2014

    Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #10
    Hmmm

    Both machines are just plugged into standard wall outlets.
     
  11. omvs macrumors 6502

    Joined:
    May 15, 2011
    #11
    I can't make out why either of those warnings came up given the settings you showed - maybe someone else has a better idea.

    This article was a bit interesting too, though I can't tell if they're talking about the normal light sleep or the hibernate mode - there's too many different terms floating around:

    http://osxdaily.com/2013/01/21/mac-slow-wake-from-sleep-fix/

    If you don't want the machine to got to sleep at all that is fairly easy to prevent, but thats a big hammer and would add to power usage. I would imagine the machine uses very low power in the normal sleep, and you just want to kill the hibernate/autopoweroff/whatever.
     
  12. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #12
    I’ll wait and see if your suggestions did the tick. I’ll update this topic in a few hours.

    Thanks for your help!
     
  13. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
  14. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
  15. pianoman88 macrumors regular

    Joined:
    Aug 20, 2010
    #15
    Power Supply Issue

    My 5.1 was doing the same thing and over time progressed to the point where I would have to press the power button dozens of times before it would start. It ended up being a power supply issue.

    After 3 trips to the Mac Store I asked to speak to the manager who immediately said "it's the power supply" and got it fixed. I had videos of my attempts to start the machine and yet the "geniuses" I spoke with couldn't figure it out.
     
  16. Pagemakers thread starter macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #16
    Hmmmm!

    This starts every time as soon as I press the power button.

    My issue is that on 30% of occasions, when it sleeps it actually turns off (or so it would seem because I have to press the power button to re-start it).
     

Share This Page