New Mac User....Dimming Problems

Discussion in 'MacBook Pro' started by JayKay321, Nov 7, 2008.

  1. JayKay321 macrumors member

    Joined:
    Nov 7, 2008
    #1
    Hello All,

    New late '08 MBP user here after going my entire life with a PC. After seeing how seamless everything was, I had to make the switch. I've done my research about all the MBP issues and so far everything seems good except for a couple of the dimming issues.

    #1: After about 2 minutes, my MBP's screen dims if I haven't moved the cursor. And yes, I have "automatically adjust brightness as ambient light changes" checked OFF. My settings for "display sleep" and "computer sleep" are set well AFTER 2 minutes. I have searched this forum and the only official answer seems to be here: http://support.apple.com/kb/TS2309?viewlocale=en_US

    Is this still the only answer/solution available? With only two days before my 14 day return policy is up, I'd really like to make sure it's not a defect in my computer.


    #2: My keyboard also dims and brightens based on how much light is in the room despite having checked off "automatically adjust brightness...."


    Are these issues bugs in the OS or computer specific issues? Thanks in advance for any help/suggestions.

    -Jay
     
  2. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #2
    For #1, go to System Preferences > Energy Saver and disable "Automatically reduce display brightness before sleep". You can choose to have this off for AC and on for battery, if you like.

    For #2: Go to System Preferences > Keyboard, and disable automatic backlighting (it's a separate switch from the screen's auto-dim)
     
  3. duffyanneal macrumors 6502a

    duffyanneal

    Joined:
    Feb 5, 2008
    Location:
    NYC
    #3
    In the Energy Saver preference panel uncheck "Automatically reduce the brightness of the display before display sleep".
     
  4. ninja10 macrumors newbie

    Joined:
    Oct 14, 2008
    Location:
    Houston, TX
    #4
    i have a similar problem with my keyboard. i have the energy saver setting to not to turn off the keyboard. after about 2 mins the keyboard turn off by itself and i have to move my mouse to light it back up. haven't found a solution yet so i will have to call apple when i have time.
     
  5. sal macrumors 6502

    Joined:
    Oct 13, 2007
    #5
    wow, this problem is still around even with the new macbook pro? I figured apple would have fixed this bug by now. anyways, this is how I solved the issue on the previous macbook pro. It's worth a shot.

     
  6. ryanwarsaw macrumors 68000

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #6
    Open terminal and copy and paste this into it and hit enter.

    sudo pmset -a halfdim 0

    Thats has solved this problem on every Mac I have owned.

    That solves the screen dimming but not sure about the keyboard.
     
  7. plinx0r macrumors member

    Joined:
    Jul 11, 2008
    #7
  8. JayKay321 thread starter macrumors member

    Joined:
    Nov 7, 2008
    #8
    Thanks for all the suggestions! Unchecking "automatically reduce brightness of the display before sleep" did the trick.

    As for #2, it appears that this setting is under "keyboard and mouse." Initially i thought the fluctuating keyboard backlight had to do with the "automatically adjust brightness as ambient light changes" setting, but apparently, completely separate things.

    Glad to have found this forum; it's a great resource for the :apple: noobs. :)
     
  9. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #9
    Hi,
    my screen is also dimming and this is perfectly right when I don't use the notebook so I don't want to deactivate it. The problem is that it dims when I'm watching a movie with VLC cos I don't want it to dim. When I watch a DVD with the DVD player it doesn't dim.



    Thanks,
    Tex
     

Share This Page