New MacBook Pro i5: "sleep" problem

Discussion in 'MacBook Pro' started by lollorenzo, Aug 1, 2010.

  1. lollorenzo macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #1
    Hi, with the old MBP C2D the sleep mode was immediate, but now with the new i5 its take several seconds... (from 20 to 30 seconds...) :(
    Is it possible to resolve the problem by deleting some preferences or in some other ways? :confused:
    Thanks
     
  2. LisaMaree macrumors member

    Joined:
    Jul 21, 2010
  3. revelated macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #3
    No way it should take that long. Mine is instant. Are you referring to the lid-close sleep, or the after-time sleep?

    In either case, did you already adjust the Energy Saver preferences?
     
  4. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #4
    I'm talking about the fact that when I click shutdown button or directly from the Apple menu option Stop (in Italian is called: Stop) the Mac instead of get in that state of hibernation immediately takes more than 30 seconds ...
     
  5. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
  6. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #6
    Strange, I had that problem with my 2009 C2D MBP. it would take at least 30 seconds to shut down or hibernate each time. I experience instant shut down/sleep with my i5/SSD.
     
  7. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #7
    Have you any idea to solve the problem? I can attach the log file(from the Console app) if it's necessary...
     
  8. walex19 macrumors newbie

    Joined:
    Jun 28, 2010
    #8
    Fix

    Had the same problem

    One thing to do is:

    The first step is to check which mode you’re in now. Use this command from the terminal:

    pmset -g | grep hibernatemode

    Make a note of which mode it is (probably 3) so that you can return to it if you want.

    Now, set your MBP to use mode 0:

    sudo pmset -a hibernatemode 0

    Then reboot.


    ANOTHER thing is..check your printer and scanner queues..there might be a print job...just delete all that (system preferences etc)

    Do both of them and it should be back to normal.
     
  9. revelated macrumors 6502a

    revelated

    Joined:
    Jun 30, 2010
    #9
    Hopefully the solution above helps. If I might ask a strange question...

    Assuming the "Stop" is the same thing as English "Sleep", why don't you just close the lid?
     
  10. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #10
    Ok, thanks! I have no scanner or printer installed on the i5.
    When tha calibration battery process finish I make your advices.. I hope this solve the problem!
     
  11. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #11
    Yes: I think that italian MBP Stop means english Sleep. If I close the lid the hibernation was immediatly?
     
  12. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #12
    Off topic: gentlemens sorry for my very bad english! :eek:
     
  13. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #13
    Now it's 0 but nothing changes... :(

    Where can I delete this system preferences...?
     
  14. michaelfengdayu macrumors member

    Joined:
    Jun 22, 2007
    #14
    You can open up the console right after you wake up the computer from sleep. you can then find what was going on when it was trying to sleep. It could be an application conflict that delayed the sleeping process, could be safari or a print job waiting in queue.
     
  15. walex19 macrumors newbie

    Joined:
    Jun 28, 2010
    #15


    Go to system preferences ---->Print & Fax, then you'll see options to delete any queues.
     
  16. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #16
    I have no queues...
     
  17. xaquaticx macrumors regular

    Joined:
    Feb 6, 2010
    #17
    I have noticed that my MacBook Pro goes to Hibernate (Deep Sleep) frequently. Specifically, when I sleep it overnight, if it is low on battery, say 10-15% or less, it'll wake up from Hibernate instead, taking 30 seconds. Hibernate, just to explain, is when the Mac saves the contents of the RAM (the computer's memory) to the hard drive. While this is nice, it usually only happens when you run the battery to 0%...AND it sits for many hours. The MacBook Pros have some power management issues, as well as many, many other manufacturing, quality and design issues. This one is minor, since it's only a few extra seconds, and I didn't even bother to write Apple about it. Just thought I would throw this in there to see if anyone else has seen this Hibernating bug. Again, it's no big deal. Hasn't seemed to muck anything up, just takes a few extra seconds to wake up some mornings. My guess is there is some firmware/software bug with calculating remaining battery life properly.
     
  18. lollorenzo thread starter macrumors member

    lollorenzo

    Joined:
    Apr 26, 2010
    Location:
    Piacenza, Italy
    #18
    I don't know... My problem it's when the MBP go to sleep... not at wake(-up)... :rolleyes:
     

Share This Page