New Macbook Pro Trackpad NOT scrolling...

Discussion in 'MacBook Pro' started by UberMac, Oct 19, 2008.

  1. UberMac macrumors 6502

    Jan 5, 2005
    Hi Guys!

    Well I got my new MBP yesterday and it's great! Then, randomly, it stopped letting me use the two finger scroll this morning... I can still pinch, rotate, use 3 or 4 finger gestures, but no scrolling!

    I've tried restarting, resetting preferences, deleting the prefences plist, permissions...

    Any ideas?


    Uber x
  2. GodOfLove macrumors newbie

    Jun 23, 2006
    Time for you to bring it to apple store... =D
  3. jjahshik32 macrumors 603

    Sep 4, 2006
    uh oh... I'm still waiting and reading about the mbp before plunging.. so far I only see some "minor" issues.. but waiting.. just incase. Especially the nvidia 9600m GT cards.. I dont want to plunk down almost 3k and find an article that saids Nvidia 9600m gt cards are burning out.
  4. UberMac thread starter macrumors 6502

    Jan 5, 2005

    Well, I phoned Apple Care and we tried a few things, reset PRAM, deleted all my caches and preferences but still no luck. Then we created a new account and low and behold, the scrolling worked!

    Problem solved I thought; create myself a new account, migrate minimal amounts of data that is on the laptop, let mobile me sync all my calendars and contacts down...job done.

    Nope. After the first restart the scrolling stopped working again. I have system preferences syncing turned on in mobile me, so I can only assume that a preference is getting confused somewhere in the sync. Shouldn't this be solved by deleting from my library though...?

    Anybody with any bright ideas?

  5. soosy macrumors regular

    May 6, 2002
    Any solution to this?

    I have one account that won't two finger scroll. Other gestures work fine (e.g. 3 and 4 finger). And 2 finger works fine in other accounts.

    It MUST be some preference somewhere, but I can't find it for the life of me. Web searches aren't giving me any luck.

    I've been working on this for hours and it's driving me crazy!!! Any help is appreciated. :)
  6. duffyanneal macrumors 6502a


    Feb 5, 2008
    Did you repair permissions? You can trash the entire prefs folder.
  7. soosy macrumors regular

    May 6, 2002
    Well, finally went with trashing the whole prefs folder even though I was hoping to avoid it. (Tried Permission repair with no success).

    Mail wanted to re-setup accounts so I copied the old prefs over. iTunes and iPhoto didn't need that to find their libraries though. Not too bad so far.
  8. KSpider macrumors regular

    Mar 29, 2006
    San Diego, CA
    Apple will tell you to do a clean install of 10.5...
  9. whoknows macrumors newbie

    Mar 28, 2008
    I'm having the same problem. One user account allows 2 finger scrolling and the other doesn't. Did anyone get this figured out?
  10. iVeBeenDrinkin' macrumors 65816


    Oct 17, 2008
  11. whoknows macrumors newbie

    Mar 28, 2008
    Yeah, I did that already and was hoping that would fix it, but alas. Very strange that it is just one user isn't it?
  12. michaell macrumors newbie

    Nov 24, 2008
    I had exactly the same problem - I migrated from an older macbook which must have messed up the preferences, and googling led me to this thread.

    There's a discussion at on this subject, and the fix worked for me. Issue the following through the terminal:

    defaults write -g 2

    and then reboot (NB just logging out didn't do it for me).
  13. whoknows macrumors newbie

    Mar 28, 2008
    Fix Works

    Thanks, that did it. I guessed it had something to do with migration but no clue what to do about it. :D
  14. parisest macrumors newbie

    Dec 14, 2008
    Thanks for the advice

    Thank you,

    I had the same problem: one account thad did two finger scolling, and one that did not (the one I migrated to from a 2005 iBook).

    now works fine, did not even have to restart.
  15. linsam macrumors 6502


    Jul 3, 2007
    Irvine, CA
    I just set-up my new MBP yesterday. I had been using a 17" PB for almost 5 years (great laptop). I used the set-up assistant and all went so smoothly. The only problem I had was not being able to do the 2 finger scroll. The fix mentioned above worked perfectly. Thanks!

    Merry Xmas to all!
  16. bladerunner88 macrumors member

    Apr 28, 2009
    Off World

    Just wanted to say Thanks for this bit of Terminal Magic! totally worked scrolling restored to late model Macbook Pro. Cheers.
  17. JoeStoner macrumors newbie

    Aug 18, 2013
    MacBook Pro Trackpad running amok!

    My MBPro 15inch (early2011) has been being weird yesterday and especially this morning with it swapping between Dashboard and Finder completely randomly (NOT in the nice way that this term is now used:)) it also highlights text, opens dictionaries and jumps to different places in a line of text!!
    I saw that the battery can expand and cause problems with clicking a trackpad so I've opened the back and done a cursory clean and only put the four corner screws back in and ALL is working as it should!
    However my Apple Care has expired and the nearest Genius Bar is nearly a 100 miles away I'd like to get to the bottom of this issue.
    Anyone had similar probs?

Share This Page