New MacBook Pro user--having issues!

Discussion in 'MacBook Pro' started by Boschfam, Nov 11, 2010.

  1. Boschfam macrumors newbie

    Joined:
    Nov 11, 2010
    #1
    I'm new and still learning and unfortunately...I'm active duty in S. Korea and can't get to many APPLE stores for some training.
    Just tried Hotspotshield so I could hopefully use Netflix but it's not working very well. I've decided to delete it/uninstall it and try something else. Problem is, I took it from the Applications folder and dumped it into the trash can. It won't let me do this and a pop up stating the operation could not be performed because the ajax server is in use. Can anyone tell me what I'm doing wrong?
     
  2. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #2
    Ajax is an IB owned way of pulling information in a way that is designed not to disturb the person using it. It's designed to perform a lot of functions in the background without the user noticing it.

    It's usually either a process you've inadvertently started on your own, or something that the site might extrapolate reasonably that it is very likely you would want to do in the near future.
     
  3. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #3
    Have a look at Activity Monitor ( Applications / Utilities / *) and select All Processes*and sort by Process Name to see where the culprit called "ajax server" may be.

    image below uses sorting by CPU as an example
    [​IMG]

    If you found it, use the Force Quit button.


    Also have a look at the following links to learn more about Mac OS X:

     
  4. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #4
    I had to look up what "Hotspotshield" was, because I didn't know.

    I'm not an expert, but I think you've just started something using the process that hasn't finished. You're probably going to be able to delete it shortly, find the process(es) and terminate them, or after restarting your system.
     
  5. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #5
    If this is the Ajax that I think that it is, it's something that is being used by a site that he has accessed. Although he might get a notice that an Ajax process or server is in use, it's not something that is on his computer.

    That's if it's what I am thinking of. The Ajax that I am thinking of is owned by Internet Brands through its acquisition of Jelsoft. It's just a way to feed information to a user without disturbing the user. He shouldn't have got any notice about it at all, so I think it's this weird HTTPS thing he's using that has tried to access information in a way that Ajax wasn't prepared for.

    Ajax is a neat thing to be using if you are running a very large site, because it will allow the user to be able to cause things to happen without causing a refresh of a complicated screen.
     
  6. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #6
    Yup.

    I just deliberately stirred a site that I know uses Ajax, and it's not showing up in my processes.

    It's either another use of the name "Ajax" (in which case they'll be hearing from lawyers, if I know these guys), or it's his Hotspotshield thingy that he's looking to force quite.
     
  7. Boschfam thread starter macrumors newbie

    Joined:
    Nov 11, 2010
    #7
    You all rock!

    I just registered and you all posted assistance within minutes. Thanks for that.
    Now I just have to alleviate my fear that if I force this to quit, it won't screw up anything. I assume after I do this it's a good idea to restart my MAC?
     
  8. Boschfam thread starter macrumors newbie

    Joined:
    Nov 11, 2010
    #8
    Got it---

    Thanks. I restarted my mac and then was able to delete the file. Appreciate the assist.

    On a side note, I'm also looking into trying out patriot internet. I'm told this somehow shows my IP address from New Hampshire---it's a pay for service site but only $25 a year. This should allow me to use Netflix for my family the 2 years we are stationed in S. Korea. Do you have any recommendations for me?

    thanks
     
  9. George Knighton macrumors 6502a

    George Knighton

    Joined:
    Oct 13, 2010
    #9
    South Korea blocks Netflix? I am surprised you have to go through these machinations.

    Many proxies, even big for-pay proxies, will slow down too much during peak periods to allow streaming, and other proxies will screw up the ability to access any potentially streaming site like Netflix or Youtube.

    You'll have to research this carefully before paying for a proxy service like that, I am afraid.

    But I am also surprised that you can't just use Netflix from South Korea.
     
  10. TheNewDude macrumors 6502a

    Joined:
    Mar 17, 2010
    #10
    On the top right cornor of your screen, on the info bar, do you see a red or green shield??

    If yes, that's the HOTSPOTSHIELD icon. You might have to right click on it and shut it down and then try to delete the program.....




    BTW, i'm Canadian and Hotspotshield didn't work too well for me either. I was trying to make Hulu work and had no luck!
     
  11. kevink2 macrumors 65816

    Joined:
    Nov 2, 2008
    #11
    I bet it is a Netflix limitation having to do with licensing rights to videos from studios. I seem to recall that it was only recently they could expand to Canada.
     
  12. TheNewDude macrumors 6502a

    Joined:
    Mar 17, 2010
    #12
    Yes, that's exactly the reason.
    Same goes for Hulu and a few other websites like CBS and NBC which can play the shows on demand online in the US but not in Canada and elsewhere.
     

Share This Page