New Macbook slow wireless! help!

Discussion in 'MacBook' started by jsousa, Oct 18, 2008.

  1. jsousa macrumors member

    Joined:
    Jun 6, 2006
    #1
    I just bought the new macbook. I have a linksys wrt160n router. I had the Macbook from 2 years ago (core duo 2.0 ghz, 2 gigs ram, airport G) running on the network. It is MILES faster than this new computer.

    I really can't stand that fact. The speed tests are MUCH less, youtube is always buffering, downloads are slow, I dont get it. Why would it not perform nearly as good as an older computer? The new one has N too, which should match up with the N in the router, so I'm lost for an explanation. Please help me!
     
  2. jsousa thread starter macrumors member

    Joined:
    Jun 6, 2006
  3. dhy8386 macrumors 6502a

    Joined:
    Aug 13, 2008
    #3
    Well my wife and I have a Macbook (white mid 2007) and MBP respectively and their wireless performance is not as good as my recent macBook alum. purchase. I get much more consistent throughput with it. I have a DLINK router.
     
  4. Kenal0 macrumors regular

    Joined:
    Sep 15, 2007
    #4
    It is tough to diagnose without any more info. First thing is I would try is connect via ethernet and see if the speed is what it should be. Then at least you can diagnose that it is a wireless issue. If speed is okay then can you try another wireless network and see if works faster. Like a public library, neighbor, work, Panera Bread. This will at least reduce the issue to your router settings and not the computers wireless. Oh yes, are you close to the router? Do you get a decent signal? More info would help.
    Kenal0
     
  5. hogfaninga macrumors 65816

    hogfaninga

    Joined:
    Aug 16, 2008
    Location:
    Chestnut Tree Cafe
    #5
    Some test sites have tested the new Macbook to the last gen one and the last gen one did much better in all the different situations they put it in. This should come as no surprise as it is general knowledge that aluminum doesn't have as good reception as plastic. My friends new 2.0 Macbook doesn't have as good reception as my black Macbook (which we knew would happen), but it is still has decent reception.
     
  6. jsousa thread starter macrumors member

    Joined:
    Jun 6, 2006
    #6
    the reception and signal strength are perfect - full bars.

    the actual speed is what is hindered.
     
  7. skye12 macrumors 65816

    skye12

    Joined:
    Nov 11, 2006
    Location:
    Austin, Tx
    #7
    Go through the settings on your airport setup utility again.
     
  8. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #8
    Might also want to try turning off IPV6 and changing your router's channel...and maybe do a PRAM reset while you're at it
     
  9. jsousa thread starter macrumors member

    Joined:
    Jun 6, 2006
    #9
    ipv6 didnt really do anything. i need to try to change the routers channel, just not sure how...
     
  10. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #10
    Maybe you should tell us what router you have so we can tell you what your config page is to change its settings.
     
  11. jsousa thread starter macrumors member

    Joined:
    Jun 6, 2006
    #11
    its in my original post. linksys wrt160n
     
  12. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #12
    Yea I have a White MB 2.4GHz (previous gen) and I've gone through 3 WRT160N routers. The download speed was hovering around 20-30kbps every time, so I just called tech support each time, they messed around w/some settings, which didn't do anything as I knew they wouldn't. IDK wat it is, but the WRT160N routers don't seem to work very well w/Macbooks. I then got an Airport Extreme and boom! its so fast and so much better than the linksys. I would say get an Airport Extreme if you can.
     
  13. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #13
    Sorry about that. Try 192.168.1.1. Have you ever set it up in the past? If not, the username is blank and the pass is admin.

    Instructions are here.


    AirportRadar is a good widget to have to see what channel you should not be picking if you are using the 2.4GHz setting.

    First thing you will want to do is go on a wired connection with the router and update the firmware.

    I assume you are only using wireless N computers with this router as it is not dual band, so I guess that widget won't help you. Though you can choose wide-band radio which linksys says is better.

    You can enable the SSID broadcast if you'd like and change your SSID in the basic settings. The best security would be WPA2. Then you choose a passphrase for the security. Next go to administration and change your password you use to enter the router page. You'll also want to change the username you use to access the router. If I remember correctly it is not in the same place as the passphrase change.

    When you go between windows make sure you save first. You should also be using a wired connection when updating the firmware.
     
  14. jsousa thread starter macrumors member

    Joined:
    Jun 6, 2006
    #14
    thanks for the walkthrough, but the router is setup. wpa2 encryption. And until the new macbook, all computers on the network are G-equipped...

    and to the gentleman above you, it can't be an issue with macbooks. my previous macbook, as listed in the original post (2 years old) works great on the wireless connection. only the new one is slow.
     
  15. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #15
    Download the airport radar widget to see if there is someone near you with conflicting channels. For example, if someone has a strong channel 1 or 7 signal you are going to want to choose channel 11 for your 2.4GHz frequency.

    Also, have you updated the firmware? You may go with a third party firmware if it is available and tweak some settings.

    You may want to just do a reset in the back of the router by holding down the button and then starting over with setting it up with the 192.168.1.1. Maybe unplug the modem and router. Then plug in the modem and let it turn back on. Then let the router get back online.
     
  16. pufftissue macrumors regular

    Joined:
    Sep 9, 2006
    #16
    The reason you're having slow wireless is because you have poor reception. Actually, I did not know that the aluminum was the reason, but I have always wondered why my mbp had seemingly poorer reception than my previous windows machines. It's not just a theoretical difference; it manifests in real life situations. I bought booster to fix this problem, but now I realize that the mbp was the problem, not my signal (I put my windows laptop in the same place and it could reliably connect, and my dorm states that they have wireless throughout the building, but my mbp could not reliably connect, whereas my other windows laptop could).
     
  17. kobefan234 macrumors 6502

    kobefan234

    Joined:
    May 12, 2008
    #17
    aluminum interferes with the signal that's why the iPhone changed to plastic!
     
  18. ti2ibal1 macrumors member

    Joined:
    Oct 8, 2008
    Location:
    Toledo, Ohio
    #18
    That's odd because my new MB 2.4 gets the same speeds as my white (plastic) MB did over my wireless network...

    Just do as the people above have said. Check your channels with radar widget and adjust if you must. I have noticed no issues with mine. In fact, my router and modem are up on the 2nd floor of my house in my office and I get better signal strength versus my girlfriends Compaq down in the basement.
     

Share This Page