New MB C2D - Connectivity Problem

Discussion in 'MacBook Pro' started by Mindgame, Dec 3, 2006.

  1. Mindgame macrumors newbie

    Aug 26, 2006
    Got black 2.0Ghz CD2 w/2GB RAM about two weeks ago, and have been relatively happy with it. However, over the past week, I have noticed it start to stall in certain places -- especially when trying to quit out of programs. Sometimes a normal quit doesn't work and I have to force quit. And I'm not talking about when the program itself is acting funky or is stalling. It happens under normal circumstances, like when I want to shut down my computer at the end of the day. It seems to happen most with Mail and AIM. But I have just decided to roll with it. However, last night it would not connect to my wireless router at home. I figured it was something with the phone company -- available local signals kept going in and out -- so I waited until this morning. Well, today, same problem.

    Airport is on. It sees my network/router/signal, but whenever I select it, it says that there was an error trying to connect. Right now, I am typing this on my G4 through the same wireless, which found the connection automatically like it always has, and like my MB was doing up until last night. That said, it's obviously not the router or signal. I've gone in to System Preferences and rechecked my network applications and everything looks fine. Any thoughts, or do I need to bring it to the Genius Bar?
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    For the first issue, do you have plenty of free space on your hard drive? If you create a new user account in System Preferences, do the problems carry through to that account?

    For the second issue, check if this Intel + wireless bug fix helps. :)
  3. Mindgame thread starter macrumors newbie

    Aug 26, 2006
    Went to the Apple Store, and was able to connect to their wireless through my airport. Nothing they could do for me.

    Tried the fix you linked, but it didn't work.

    Called my ISP and made several attempts at creating new location accounts under different names and re-entering the correct router/ISP info. Nothing worked, so I got transferred to the next level tech support. We tried deleting my permissions and keychain and re-entering them all again. Still nothing. Finally, we had to go in to the router electronically and reset the router name and password. Now I can connect fine, but have to enter new information in to the other two computers that share this network.

    It just doesn't make any sense to me since the two other Macs in this house could use the same router with the old name and old pass just fine. And this one was working fine up until a few days ago when it just decided to stop recognizing my connection for seemingly no reason. But whatever, it's working now.

Share This Page