New MBA- won't work with my interface like my old MBP?

Discussion in 'Digital Audio' started by ki2594, Jun 28, 2012.

  1. ki2594 macrumors 6502a

    Apr 12, 2008
    Carmel, IN.
    Hey all,

    So I record with a Saffire 6 USB interface/Audio Technica mic set up.
    I had an '09 MBP and all it took was the saffire driver and everything worked flawlessly in garageband and logic.

    With my new '12 MBA (specs are in my sig), the interface shows up and all however I get no sound from the monitor headphones. When I mess with audio midi settings and somehow get it randomly working, the vocals I record seem delayed by about a half a second. Can anyone help me? I have emailed them for help but nothing has worked so far.

    (er i should add in, i feel like the new machine would be plenty powerful to use the interface and also record without any lag)

    Thank you!
  2. Kenaudio macrumors member


    May 6, 2012
    Hello Ki!

    Can you describe a little closer, when you don't get any monitor signals? I am sorry, because I don't know the Saffire Software, but do you mean the monitoring inside Logic or the audio interface's software? Sometimes anything is working in Logic or in an audio interface's software....

    Let me know if you could solve the problem somehow...


Share This Page