New MBP - 13.3" and External Display

Discussion in 'MacBook Pro' started by nefan65, Oct 14, 2010.

  1. nefan65 macrumors 65816

    nefan65

    Joined:
    Apr 15, 2009
    #1
    Okay, just got a nice shiny new MBP 13.3". It works fine; both on/off power. No issues at all. However, I bought a new Mini Display Port for an HP L1908w monitor for a secondary display. I plug it in, the monitor sees it, then after about 5 - 10 minutes, both displays go blank [monitor and MBP display], and I can't get them back. I have to power the system off completely, and reboot.

    Any ideas?
     
  2. nefan65 thread starter macrumors 65816

    nefan65

    Joined:
    Apr 15, 2009
    #2
    Okay, I THINK I may have fixed the issue, but we'll see. I ended up resetting the PRAM, then changed the power settings while powered on to not sleep for like 2 hours, or something. I also changed the settings for my external to disable power settings, and just let the MBP use the screen saver settings.

    So far, so good. It's been an hour since I had the issue [which was happening in like 10 minutes; the original settings for the external monitor]. It was almost like the external monitor was forcing the MBP to sleep and not allow it to come out of sleep..weird.
     
  3. nefan65 thread starter macrumors 65816

    nefan65

    Joined:
    Apr 15, 2009
    #3
    AHHHHHH...didn't work. I left it unplugged from the external for a bit. Worked fine. Plugged it back in, and same thing. MBP went blank, the external had a weird beige color to it, and nothing. No movement could wake it, or get the display back. Repaired permissions, reset PRAM...what gives?
     

Share This Page