Resolved New MBP (2011), SSD and hibernation hell

Discussion in 'MacBook Pro' started by Thor774, May 24, 2011.

  1. Thor774, May 24, 2011
    Last edited: May 18, 2012

    Thor774 macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #1
    Hello

    I am really frustrated with this issue. I had no idea that the Macs were having so much problems with SSDs. I just bought a 13" MBP and separately bought RAM to upgrade it and a Corsair F120 SSD. What I found is that the MBP cannot wake from deep sleep (hibernation), it just freezes with an error, then at restart I get a kernel panic error. The machine works great in everything else. When I read the forums there appear to be hundreds of posts about problems with SSDs installed on Macs.

    The SSD came new with firmware 2.0 so there is nothing newer to install.

    I will be upgrading to Lion when it comes out but this situation really sucks. The same F120 works great on another machine with Windows 7, no hibernation problems there.

    I appreciate any light you can give me on this.

    Thanks a lot.
     
  2. DePaulBlueDemon macrumors regular

    DePaulBlueDemon

    Joined:
    Sep 27, 2010
    #2
    Happens to me, too. Patiently waiting for Lion...
     
  3. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #3
    Strange i can't say i've had any sleep issues but then again i don't use deep sleep anymore...
     
  4. ELA2 macrumors member

    Joined:
    Apr 21, 2011
    #4
    In doing my research on SSDs, your current problem was my worst nightmare. Thats why I stuck with the Apple SSD. Do let us know how you resolve this problem.
     
  5. pedrofan macrumors 6502

    Joined:
    Jun 9, 2008
    #5
    Just buy sandforce driven SSDs. The fastests, don't need trimm and now they are all fixed for the hibernation problem.
     
  6. maclaptop macrumors 65816

    maclaptop

    Joined:
    Apr 8, 2011
    Location:
    Western Hemisphere
    #6
    I've had very good luck with OCZ and a few others.

    The link below lists the brands of SSD's that will work fine with your MBP.

    I'm on my third install I did two 2010's and my new 2011 that finally came back today. They are all fast, stable and quiet.

    http://goo.gl/Smn4D

    Good Luck
     
  7. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #7
    the Corsair F120 is sandforce driven!

    see here
     
  8. Thor774 thread starter macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #8
    Yes, as said before the F120 is Sandforce driven.
    So no solutions for this? The worst is that no one can say that Lion is going to fix this issue. Really bad from Apple IMO.
     
  9. entropy1980 macrumors regular

    entropy1980

    Joined:
    May 14, 2003
    Location:
    Canyon Country, CA
    #9
    According to Corsair's forums there is a firmware update that will address the issue coming soon it's being validated... although I think saw you get that answer on that forum as well....
     
  10. device manager macrumors newbie

    Joined:
    May 27, 2011
    #10
    FWIW my 2011 MBP 13" w/ Vertex 3 120GB MI (f/w 2.06) does not freeze coming out of sleep or hibernation.
     
  11. jimbo1mcm, May 29, 2011
    Last edited: May 29, 2011

    jimbo1mcm macrumors 68000

    Joined:
    Mar 21, 2010
    #11
    Not sure if this will help, but...

    I put a Samsung 470 SSD in my 2011 MBP 13. Since it was new, I didn't really have any data to move. I put the drive in and then used Disk Utility to partition it as a GUID with one volume. I then used the OSX install discs and put the operating system in. It seems to be working perfectly. I did also install the Trim hack and it shows that it is enabled. Good luck.

    Also, put the original RAM back in and see if everything is normal, then march on.
     
  12. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #12
    Why not turn off hibernation until the firmware issue gets sorted out?
    Use the Terminal application, and the pmset command:
    pmset -g (will list all the current power settings/device settings)
    man pmset (Shows all of the manual for the peset -a command)

    1. set hibernate mode to 0
    sudo pmset -a hibernatemode 0
    hibernationmode 0 is normal sleep, kept in ram nothing written to hdd
    hibernationmode 3 is safe sleep, kept and loaded from ram, written to hdd in case of power loss
    hibernationmode 25 is full hibernation, memory is written to hdd and then ram is powered off
    Manual says mode 1 (and 5) are "not recommended"
    --------------------------------
    2. delete the unnecessary sleep file to regain disk space equal to memory (saves the same amount of disk space as your RAM, eg. 8 GBs), since hibernate is disabled

    if you want to reclaim the space the hibernate file takes up (valuable on an SSD), you can use the Go to folder menu for that. The file is found in the /var/vm/ folder, and is named sleepimage. Simply delete that file, after a reboot. Or use this:
    sudo rm /var/vm/sleepfile
    :cool:
     
  13. tasslehawf macrumors 6502

    Joined:
    Jun 13, 2003
    Location:
    Austin, TX
    #13
    You have to shut off hibernation - or simply prevent the computer from going to sleep, even on battery (you can still close the lid). You just have to be mindful of not letting the battery die completely.

    I love my Mercury SSD; the hibernation issue is a really minor trade-off. The perfomance of the SSD is amazing.
     
  14. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #14
    Have you thought of switching back to the original RAM and see if the problem still exist? You changed both at the same time so the logical thing to do is eliminate one of the modifications to see if the issue is resolved.

    Bad memory can cause sleep problems as well.
     
  15. Thor774 thread starter macrumors regular

    Thor774

    Joined:
    Sep 14, 2007
    #15
    Solved :)

    Problem solved with he latest firmware update from Corsair made available early this year.

    They took their time but at least they delivered a fix.

    Updated from MBP without needing to mount the disk on a PC, but you need a Windows LiveCD for this and some changes in the partitions.

    Go to Corsair forums to read more about updating the hard disk from a Mac
     

Share This Page