New MBP, Boot Camp'd XP, No Audio ( I Searched... )

Discussion in 'MacBook Pro' started by TurboSC, Mar 5, 2008.

  1. TurboSC macrumors 65816

    TurboSC

    Joined:
    Aug 4, 2007
    Location:
    California
    #1
    Well I just got my new updated MBP, and I slapped Boot Camp and Windows XP on there, only to find out that the audio does not work, AT ALL.

    I've searched for hours for a solution, I've tried re-installing from the Leopard CD, nothing is working.

    I just want sound to work in XP so I can ultimately play Call of Duty 4... Which by the way crashes every time I start it up, so that's swell.

    if anyone could please help me out, I would greatly appreciate it... I would have imagined this problem wouldn't exist anymore, but alas, here I am pulling my hair out trying to get this damn thing working.

    Thanks in Advance,

    - Sunny
     
  2. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #2
    When you say you've tried re-installing from the Leopard disc, you are referring to the drivers?
     
  3. TurboSC thread starter macrumors 65816

    TurboSC

    Joined:
    Aug 4, 2007
    Location:
    California
    #3
    yea.

    It will always get to the SigmaTel / RealTek driver portion and say that an instance is already running... I've tried uninstalling all audio drivers and manually browsing the Leopard Recovery CD and installing drivers that way, no luck.

    I've also followed a few guides online that didn't yield any results...

    Also if anyone knows how to fix the "popping" and noise from the speakers I'll take that in this thread as well, I'd rather keep all the information in one place in case anyone else is having this problem...
     
  4. McBeats macrumors 6502a

    Joined:
    Apr 10, 2007
    Location:
    erf
    #4
    have u tried just gettin a USB audio interface? i use one that came with my studio mixer and it fixed my noise problem. u can pick up one for under 100 bucks im sure... yeh yeh i know, something else u gotta buy, but hell... u bought a mac so u cant be broke.
     
  5. Andrmgic macrumors 6502a

    Joined:
    Jun 27, 2007
    #5
    This may be an odd question, but what file system is your Bootcamp partition?

    I saw a post from a user on another board that had trouble getting the audio drivers to work on a FAT32 partition. He reformatted the partition to NTFS and it worked fine.

    I wouldn't think that file system would matter, but it certainly wouldn't hurt if your partition is FAT32.
     
  6. wesrk macrumors 6502a

    Joined:
    Nov 4, 2007
    #6
    Same problem here, and I've also looked for a solution for a few hours and came up empty.

    I reinstalled the drivers and nothing.
    I get the same "... already running" message.

    A lot of people seem to be having this problem, the solution should not be to buy something else, I'm sure as more people complain about it someone will come up with some sort of solution, but in the mean time there's little we can do but keep searching for an answer...
     

Share This Page