New MBP firefox quirks?

Discussion in 'Mac Apps and Mac App Store' started by m3kilpat, Aug 10, 2009.

  1. m3kilpat macrumors regular

    Joined:
    Jul 6, 2009
    #1
    I've noticed a few quirks in firefox on my new MBP that are annoying and was hoping someone knows the solution.

    1. Firefox doesn't save my passwords (nor ask me to) even though the option is set to save passwords. How can I fix this?

    2. When opening a link via mail, ichat, etc. and firefox isn't already open, it will open firefox but just go to my homepage. I must click the link a second time after ff is open to actually direct to the link.

    On a separate note I tried playing a .ts file with vlc this morning but it didn't work. Anyone have any ideas offhand or do you think it's a bad ts?
     
  2. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #2
    Possibly a corrupt Firefox profile. You could try deleting the old one and creating a new one. Google for instructions.
     
  3. crazyxzer0 macrumors 6502

    Joined:
    Oct 28, 2008
    #3
    what he said.

    I don't have any problems with ffox 3.5. I also stopped using ffox password manager and using 1password since you can use that on safari as well :)
     
  4. lamadude macrumors 6502

    Joined:
    Jan 12, 2006
    Location:
    Brussels, BE
    #4
    Looks like you will have to reinstall. I have non of the problems you described with FF 3.5 on my mbp
     
  5. m3kilpat thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #5
    I don't see why things would get messed up like that. I just bought the mac and firefox was like the first thing I put on. In any case, I will try reinstalling it when I get home today.

    Actually now that I think about it I did use xslimmer on a bunch of programs and firefox was probably one of them. Maybe it stripped some necessary files. I will restore with that first and if that fails reinstall ff. I will update as to what the problem is after I figure it out.
     
  6. m3kilpat thread starter macrumors regular

    Joined:
    Jul 6, 2009
    #6
    Ok so I'm an idiot. I tried using the backup for xslimmer. Didn't fix it. Tried reinstalling. Didn't fix it. Realized that having all history turned off in preferences was the issue. I thought that option was only for browsed history and not form history as well.
     

Share This Page