New MBP lousy PAN tethering - Anyone else?

Discussion in 'MacBook Pro' started by JohnnyGTO, Oct 19, 2008.

  1. JohnnyGTO macrumors newbie

    Joined:
    Oct 19, 2008
    #1
    I have been tethering my older MBP with an AT&T Tilt for the last year with great success and fast performance. Yesterday I went through the routine of pairing my Tilt to my new MBP (late 2008) and everything work up until I try and use the connection. Performance is extremely slow 2-3k and has long pauses.

    One thing pairing with the old MBP is very quick, the computer queries and gets the device details i just a few seconds. When I pair the new MBP after entering the pairing code the phone stalls for a good minute before it says its finished.

    Any ideas?
     
  2. Mactagonist macrumors 65816

    Joined:
    Feb 5, 2008
    Location:
    NYC - Manhattan
    #2
    The MBA had very similar issues when it was new relating to a different BT stack being used by Apple.

    Search in the Air forum for more information. I dont remember what the resolution, if any, was.
     
  3. MazingerZ macrumors 6502

    MazingerZ

    Joined:
    Aug 22, 2007
    #3
    Yep, I have the same issue with the Macbook Air. Long ping times that gets worst as you try to surf. AFAIK, there wasn't a resolution to the issue in the latest updates. Looks like the problem has now migrated to the new machines as well.

    To get around the issue, i stopped using tethering via bluetooth and use joiku or walking hotspot on my Nokia phones to create a wifi network. This really works well but the phone has to be plugged to power since wifi will kill the battery in 45 minutes.
     
  4. JohnnyGTO thread starter macrumors newbie

    Joined:
    Oct 19, 2008
    #4
    So all this time with no fix AND they did it again? I;m using a Tilt I don't know if there is a way to tether via USB or Wifi?
     
  5. JohnnyGTO thread starter macrumors newbie

    Joined:
    Oct 19, 2008
    #5
    Just an update, I spoke with Apple care and got kicked upstairs to a product specialist. We tried the usual delete the plist, reset pram etc. Now I'm doing an erase and install and will call them back with the results of the test. If it work great if not they are going to send me to an engineer.

    I'm also considering going back to the store and talking them into testing with a couple of there demo models, see if it's mine in particular or the new MBP in general.
     
  6. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #6
    I hope this doesn't count as a threadjack, but I believe there is something at issue with the bluetooth in general with the new MBPs.

    I've got a wireless Mighty Mouse and a Logitech cordless laser mouse. Both of them will pair occasionally but most times the pairing fails. Even after successfully pairing, the devices won't reconnect the next time you turn them on.

    When pairing in Windows, it says the mice are successfully installed, but they never work.

    I really like my new MBP, but I'm seriously beginning to consider returning it. A $3000 laptop should have functional bluetooth. I really hope that if anyone comes up with any resolutions to the bluetooth issues They will post them.
     
  7. JohnnyGTO thread starter macrumors newbie

    Joined:
    Oct 19, 2008
    #7
    I'll test mine, I'll "borrow" my Dad's bluetooth mouse and KB
     
  8. r88my macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    Manchester UK
  9. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #9
    The name of a Windows Mobile phone sold by AT&T. :)
     
  10. r88my macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    Manchester UK
  11. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #11
    That would be helpful. I appreciate any input you can provide.
     
  12. MazingerZ macrumors 6502

    MazingerZ

    Joined:
    Aug 22, 2007
    #12
    Maybe you just have faulty unit. My MBA never had any other issues with bluetooth besides the tethering issue.
     
  13. JohnnyGTO thread starter macrumors newbie

    Joined:
    Oct 19, 2008
    #13
    I've tested my new MBP with a Genius and then several demo MBP, none work with PAN tethering. So far the bluetooth keyboard pairs and repairs ok.
     

Share This Page