New MBP - Thunderbolt drive disconnected when touched

Discussion in 'MacBook Pro' started by comatory, Nov 4, 2014.

  1. comatory macrumors 6502a

    comatory

    Joined:
    Apr 10, 2012
    #1
    OK so I have this weird problem that has caused me volume failure already. This MBP is late 2013 model bought last week from refurbished store. I have a WD My Passbook Pro drive and it's acting weird.
    When I for example just slightly move the cable (or tap the top of the end), the drive ejects itself. I tried switching ports and the same thing happened on the other port too. Sometimes it doesn't happen at all but when I unplug it and plug it in I can replicate the problem in 2-3 tries.
    Hm, so I thought faulty cable or whatever. OK I got different TB drive made by Seagate. Same thing happens with this drive too. When I try this on different Macbook Pro Retina (late 2012 model), everything is OK there.
    This leads me to conclusion that my hardware might be faulty. I tried googling this problem but didn't find anything. My MBP is of course with warranty but I'm doing a professional work on it and I can't really afford any downtime so I'm trying to figure out what's wrong.
    I'm running OS X Yosemite and it's giving me trouble too, mostly graphical glitches and computer froze few times.

    I'll try SMC reset but I'm not sure it will solve anything.
     
  2. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
    #2
    Does the USB connector feel loose in the socket?

    If it works properly in your other Mac, I'd say return it and try again with a different one.
     
  3. comatory thread starter macrumors 6502a

    comatory

    Joined:
    Apr 10, 2012
    #3
    USB and TB ports seems to be ok, I don't feel any unusual wiggle. You can do a slight movement in the port but it's like on other computers.

    Anyway, I'm knocking on wood, I did SMC reset and it seems to be working normally now. I tried 10x times each port, tapping on top of the cable and wiggling in slightly from side to side and it hasn't disconnected yet so hopefully it'll be allright.
     

Share This Page