New MBP won't rip any DVDs - Help!

Discussion in 'MacBook Pro' started by jomama7366, Nov 10, 2009.

  1. jomama7366 macrumors member

    Joined:
    Nov 1, 2008
    #1
    Just got a brand new uMBP (mid 2009); came with 10.6.2; migrated all my stuff from a backup of my old computer (which was running 10.5). Every program seems to run great, except that I cannot get Mactheripper (or Ripit) to rip any DVD. (My old Mid-2008 MBP, running 10.5 had no issues.) MTR opens, seems to do a rip in a very small amount of time, say 3 min when it should take 30, but says bad sectors, all that. I "reinstalled libraries," and it still failed.

    FWIW, Ripit fails with the burn after a few seconds. This is on more than one disc, for both MTR and Ripit, which tells me this might be about my system.

    The Superdrive plays DVDs fine, btw.

    Is there a pref file I need to trash, or something like that which might "reset" something to allow my drive to rip anything?

    Is this an issue with Snow Leopard? Something else in the system?

    Please help!....
     
  2. MacModMachine macrumors 68020

    MacModMachine

    Joined:
    Apr 3, 2009
    Location:
    Canada
    #2
    sounds like you have a bad DVDRW drive ,

    have you reinstalled the programs you rip with?

    also try to repair permissions under disk utility.
     
  3. Badger^2 macrumors 68000

    Badger^2

    Joined:
    Oct 29, 2009
    Location:
    Sacramento
    #3
    why not just reinstall MTR?

    or give handbrake a try?
     
  4. jomama7366 thread starter macrumors member

    Joined:
    Nov 1, 2008
    #4
    Doh!

    Okay...one of those "duh" moments. I tried playing a movie, and something popped up saying the region on my drive did not match the disc. Apparently, the drive was set to China (region 6). So I set it for region 1, and it played the disc. Now, MTR seems to be ripping properly....

    Ah...relief.

    Thanks for the help, guys. :)
     

Share This Page