New mini= monitor is fuzzy, help

Discussion in 'Mac mini' started by rwm514, Jul 17, 2010.

  1. rwm514 macrumors member

    Joined:
    Jul 30, 2008
    #1
    Just upgraded from an old mac mini to a brand new one. I also recently purchased a new 25 inch hannspree monitor which I used with my old mini no problems. The monitor has 2 hdmi inputs and an old style pin input (vga?) The picture is now quite fuzzy and soft whereas before it was crisp. Im just going straight from hdmi on the mini to hdmi on the monitor. Am I missing something? Before I used a hdmi adaptor to hook up the old mini. Please help :) thx
     
  2. Beaverman3001 macrumors 6502

    Joined:
    May 20, 2010
    #2
    Sounds like you just need to spend some time with the Display settings.
     
  3. iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #3
    What's the native resolution of the monitor? (should be in the specs)

    You want to make sure your mac is set to output that resolution to avoid it scaling the image (which can look fuzzy).
     
  4. rwm514 thread starter macrumors member

    Joined:
    Jul 30, 2008
    #4
    It is 1920x1080, I put the settings at 1080p which seems to be the only one that is even close. Doesn't seem like there are any other adjustments really.
     
  5. iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #5
    1080p should map exactly to 1920x1080, so there should be no scaling or fuzziness.

    Is there an 'options' tab in the displays? Try toggling 'overscan' to see if that makes a difference or not.
     
  6. rwm514 thread starter macrumors member

    Joined:
    Jul 30, 2008
    #6
    I read in another thread here that someone needed to use the dvi port on the mini with an adaptor to get the fuzziness to go away. Does that make sense? Thx
     
  7. fruitpunch36 macrumors newbie

    Joined:
    Dec 21, 2009
    #7
    How'd you connect the old Mini to the monitor? If it was a DVI-HDMI adapter, try plug it into the HDMI-DVI adapter the new Mini came with and see if that helps
     
  8. rwm514 thread starter macrumors member

    Joined:
    Jul 30, 2008
    #8
    Thx for the tip, I tried that with the same result:(
    Just picked up a dvi to hdmi adaptor at best buy $30:(
    Well see if that works, they said it would but I don't really see why
     
  9. ValSalva macrumors 68040

    ValSalva

    Joined:
    Jun 26, 2009
    Location:
    Burpelson AFB
    #9
    How about connecting to your monitor with an HDMI cable. You said the monitor has HDMI input and the Mini has an HDMI output. That's probably the most direct digital connection without the need for any adapters and should provide the optimum video output.
     
  10. Giuly macrumors 68040

    Giuly

    #10
    Set the monitor to 1920x1200@60Hz with SwitchResX and your fuzziness goes magically away. Computer monitors are 16:10 and not 16:9, and so use a resolution of 1920x1200 whereas 16:9 HDTVs use 1920x1080.

    Mystery solved.
     
  11. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #11
    Are you sure about that? The OP even said the native resolution for the monitor was 1920x1080.

    OP, is your HDMI cable compatible with HDMI 1.3? I had a problem with mine and it was due to a cheap HDMI cable.
     
  12. Giuly macrumors 68040

    Giuly

    #12
    OK, it's that one, which is indeed 1920x1080. Sorry, my fault, but the European hannspree website states only 1920x1200 models, so are most 24" ones - including the old iMac. Sure, that may not apply to the uncommon 27" screen of the new iMac, Cinema Displays however are 16:10. Most != all.
    There's a table inside the PDF with horizontal and vertical frequencies, try setting these to the corresponding value with SwitchResX. It also states that if it doesn't work correctly with 60Hz it could work with 50Hz and vice versa, you could try that too with SwitchResX. An incorrectly calibrated color scheme can cause this too, but it would be more washed out then fuzzy. Try to get the Windows Driver for the Monitor (if available), extract the icm and/or icc file(s), put them into /Library/ColorSync/Profiles/Displays/ and set the color profile in the monitor section of the system preferences.

    Or the cheap wire, especially if it's longer then 5m or 16' - or not corresponding to the HDMI 1.3 specification.
     

Share This Page