New OS X Yosemite 10.10.3 Update STILL has Wi-Fi issues

Discussion in 'OS X Yosemite (10.10)' started by Lightore, Apr 9, 2015.

  1. Lightore macrumors newbie

    Joined:
    Apr 9, 2015
    #1
    So I just updated my OS X hoping the wifi issue will be resolved, yet nothing has changed :mad:

    I have this issue mainly on my universities campus so i figured is might have something to do with their server messsing with my wifi connection which results in the wifi symbol indicating im connect yet I can not go on any websites on chrome.

    Also a weird thing I noticed, when im working on a google doc or presentation and this happens i can still see my group members edit but i cant type anything. I just have a trying to connect message at the top of the page :/

    If anyone could help me out it would be much appreciated. Last night i tried figuring out how to connect to a google dns because i heard it has helped resolve the issue for some users.
     
  2. GIFF64 macrumors newbie

    Joined:
    Mar 11, 2012
    #2
    wifi issues

    yer having same problem even after update's still dropping out everyday tried to find an email to contact apple support no joy getting fed up now
     

Share This Page