New OWC SSD on MBA 2012

Discussion in 'MacBook Air' started by dtatl, Apr 25, 2015.

  1. dtatl macrumors newbie

    Joined:
    Apr 25, 2015
    #1
    I have a MBA 11" 2012 with the original 64 GB SSD that I bought about 2 years ago. I should have known better that that was not sufficient.

    I went and bought the OWC SSD Aurora 240 GB to swap out the 64 GB. I installed it and it recognizes it but when I try to reinstall the OS X it took like 18 hours, but then took very long to boot and I never let it complete because it seemed to hang.

    I contacted OWC and they told me the "Command R" and reinstall is done by Apple and didn't have anything to do with the SSD. I reformatted the drive and tried again but said the same thing.

    So instead I went to my Time Machine via USB and restored which worked, I had to shut down the machine because it hung in the "restart" process but after it booted fairly quick.

    To make a long story short. SOME applications work as expected but then on others it does a lot of beach balling especially when I do anything with the system preferences. It is just not performing like the original.

    Is this normal for a 3rd party or is the a clear cut bad SSD or am I expecting too much? I paid $219 so it wasn't cheap.
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Sounds like you have a bad drive there. I would get my money back and buy the Transcend as flowrider mentioned. OWC uses Sandforce controllers in their drives that seem to be problematic for a lot of users.
     

Share This Page