NEW! quake 4 in macgamestore: sys requirements have been changed completely?!

Discussion in 'Mac and PC Games' started by macaddict77, Mar 25, 2012.

  1. macaddict77 macrumors newbie

    Joined:
    Sep 9, 2008
    #1
    http://www.insidemacgames.com/news/story.php?ID=20703

    this is what they say:

    Requirements:
    Operating System: 10.6.8 (Snow Leopard), 10.7.3 (Lion)
    CPU Processor: Intel Core 2 Duo (Dual-Core)
    CPU Speed: 2.4 GHz
    Memory: 2 GB
    Hard Disk Space: 3.5 GB
    Video Card (ATI): Radeon HD 2600
    Video Card (NVidia): Geforce 8600
    Video Memory (VRam): 256 MB


    here is a link from 2006 with the original sys req:
    http://www.macworld.com/article/1049219/quake4.html

    According to Aspyr, Quake 4 will require Mac OS X v10.3.9 or later, G4, G5 or Intel-based Mac running at 1.67GHz or faster, 512MB RAM, 3GB hard disk space, ATI Radeon 9600 or Nvidia GeForce 6600 or better 3D graphics with at least 64MB VRAM, DVD drive, and TCP/IP-based Internet or LAN connection for online play, which will be cross-platform.

    LOL WTF???!!!

    i instantly noticed something was wrong when i read that it requires 256mb of vram because my imac from 2007 with 128mb of vram can run it smoothly...
    not just that, but also the processor info doesn't match up! i know almost everyone nowadays has an intel mac and that they probably recompiled the game or somehting for the digital release... but come on!

    what's going on here?
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Maybe the default settings are much higher..?

    I dunno...?
    Take a look at Doom 3:

    Doom 3
    Original Mac requirements:
    Mac App Store Mac requirements:
     
  3. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #3
    It's part of the changeover to requiring Intel. They're not going to list a bunch of PowerPC only cards on there, instead they'll move over to the Intel cards.

    Radeon 9600 and GeForce 6600 only shipped for PowerPC Macs, not Intels, so why have them as the baseline? Just confusing.
     

Share This Page