New rMBP wont recognize USB boot drive....

Discussion in 'MacBook Pro' started by NukeIT, Jul 17, 2013.

  1. NukeIT macrumors regular

    Joined:
    Mar 20, 2013
    #1
    Since the New rMBP's dont come with a boot disk, I wanted to create a backup... after researching how to get a copy of the installed, etc etc...

    I downloaded the installer thru the Recovery via Internet... then downloaded a copy of Lion Disk Maker....

    I have a 64 GB Kingston USB 3.0 Flash drive that is partitioned into 3 partitions, 2 x 16 GB and 1 x 32 GB

    Ran the Lion Disk Maker and it created the bootable USB on 1 of the 16 GB partitions...

    When I restarted, while holding "option" it only shows me the Normal SSD and the Recovery partition (all part of the internal SSD)

    When I look thru ( Systems Preferences>Startup Disk) the USB shows up... also the USB shows up if I boot via "command+R" and then tell it to reboot via the USB, however it fails and flashes the "folder w/question mark on it" while starting up.... so that doesnt work either....

    I have tried both USB slots, the drive does have an LED on it to show activity, and it does not flash while I am trying to boot from it....

    So what am I doing wrong???

    (sorry for the long post, was trying to give all the info, and what I have tried already)
     
  2. andeify macrumors 6502

    andeify

    Joined:
    Jun 10, 2012
    Location:
    UK
    #2
    Sounds like somethings gone wrong while making the disk, try making the boot disk again
     
  3. newdeal macrumors 68020

    Joined:
    Oct 21, 2009
    #3
    Someone else on here recently mentioned the same problem with a usb 3.0 drive. He switched to usb 2.0 drive and problem solved
     
  4. dastinger macrumors 6502a

    dastinger

    Joined:
    Mar 18, 2012
    #4
    Maybe the issue is with having so much partitions. Try with less partitions.
     
  5. trigonometry, Jul 17, 2013
    Last edited: Jul 17, 2013

    trigonometry macrumors 6502

    trigonometry

    Joined:
    Jun 19, 2010
    Location:
    South Carolina
    #5
  6. cbs20 macrumors member

    Joined:
    Feb 26, 2013
    #6
    It's because it's USB 3.0. The retinas are very fussy about what USB 3.0 drives they can boot to. It seems that not all USB 3.0 devices can be booted to with the rMBP. I would recommend filing a complaint with Apple.
     
  7. NukeIT thread starter macrumors regular

    Joined:
    Mar 20, 2013
    #7
    So I tried an older USB 2.0 8 GB drive and had the same result... Reformatted the drive again making sure to setup a GUID partition, and used Lion Diskmaker again, that time getting an error on the installer due to missing files...

    So I decided to try and download Mountain Lion again via internet recovery...

    installed it directly onto the USB 3.0 Drive, rebooted and continued the install as well as the Apple Setup.... So no need for Lion Diskmaker etc.... and it a WORKS!!! WOOT WOOT

    I did notice that the drive has to be inserted only partially for the system to recognize is during the boot process... If it is pushed in all the way it doesnt see it, but if I boot to the select disk (alt boot) and then insert the USB untill it is recognized it works fine.... (which doesnt make sense, since the system sees the drive any other time when it is fully inserted...

    Moral of the Story:

    Just download ML via internet Recovery directly to the drive, install, and setup... dont mess around with getting the .pkg or .dmg and using Lion Diskmaker..... and if your system doesnt see the drive try only pushing it in part of the way....
     

Share This Page