New Seagate Expansion HDD's Will Not Format-Sierra

Discussion in 'Mac Basics and Help' started by Wie Gehts, Aug 4, 2017.

  1. Wie Gehts, Aug 4, 2017
    Last edited: Aug 4, 2017

    Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    I've never encounter any problem formatting drives and this is driving me nuts as I've recently moved to Sierra.

    Two brand new Seagate Expansion drives, they fail to format with disk utility. Not only that, they'll unmount and no longer are recognized.... like they are damaged or something. However the 'ghost' of the drives still show in DU and DU still 'sees' them.

    First thing I tried, I formatted to FAT and ExFAT and they formatted. But when I then tried Mac format, same thing happened. I'm thinking, maybe it's Sierra.

    I plug one of the drives into my old MacBook with Snow Leopard and the drives formatted. Hurray! Well no because when I connected to my Sierra OS Mac, the same bloody thing happened when I tried a format.
    Oh Yeah, and DU is telling me these drive have 2.2 or 3TB USED space!

    You might say well why didn't I leave well enough alone but even still, if Sierra won't format then something bigger is wrong. There is definitely something up with Sierra.

    Oddly enough I also recently bought a 6 & 8 TB Seagate's and had no problem formatting them!
    I can't recall but I may have formatted those earlier two before the last Sierra update. Hmmmm.

    Any ideas folks?
     
  2. Audit13 macrumors 68030

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Tried deleting all partitions and recreating partitions?

    If these were formatted for a windows machine, change from mbr to guid.
     
  3. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #3
    Not sure what your saying by deleting and recreating partitions. I did try formatting both via erase and partition to the same result if that's what you mean. Always GUID as well.

    I went back and formatted both drives on my MacBook/snow leopard machine. They then showed the proper 3tb available. I plugged them into my Mini/Sierra machine and transferred 2tb worth of data to each. They behaved normal. I also did a disk check/repair and disk utility behaved normal. I did a rebuild with DiskWarrior and that had no problem.
    Therefore apparently Sierra recognizes them as valid disks. It just wouldn't format them for some reason! Strange, very strange.
     
  4. Audit13 macrumors 68030

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    That is strange because I have a 3tb wd and 3tb Seagate, both of which had no problem being changed from mbr to guid and formatted as a single partiton. These drives get moved among 4 Macbooks without a problem. One is on El Capitan and others on Sierra.
     
  5. Wie Gehts, Aug 5, 2017
    Last edited: Aug 5, 2017

    Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #5
    Yeah, like I say I recently formatted 6 & 8tb Seagate's on this machine as well as a couple WD bare drives.
    However, Seagate enclosures have always been known to be a bit squirrelly for the mac community, lol.

    Hope this isn't some kind of hardware problem on my mini. Don't have time now but I'll run the hardware diagnostics later and I also have some older empty seagate drives lying around to see if they'll format. I'll come back tonight with results.
     
  6. Audit13 macrumors 68030

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #6
    Hopefully, it's just nothing more than a temporary glitch.
     
  7. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    Do the Seagate drives have any kind of proprietary software "bundled in" with them?

    Do they have any kind of "hidden partition" on which this software resides?

    This is why I never buy "factory-assembled" drives.

    I buy "bare drives", enclosures, and assemble them myself.
    They ALWAYS "format out" correctly... ;)
     
  8. Audit13 macrumors 68030

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #8
    I think the Seagate comes with software, that being Paragon utilities to allow NTFS drives to have read/write under macOS.

    I eliminate all hidden partitions and pre-installed software, I usually use my Windows machine and diskpart commands to clean the drives before being used in Win7/10 or macOS.
     
  9. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #9
    Thank you guys, you gave me the way to sort it out. I do have a windows laptop so I wound up googling this 'diskpart' thing and actually found very simple clear and concise instructions oddly enough on seagate website. :)
    Drives were then able to be formatted with Sierra.

    So annoying. Why in gods name do they have to stick some kinda 'microsoft reserve efi recovery or whateverthehell it is stealth partition on there that can only be removed via some bit of command line arcana and not simply in disk manager. Grrrrrrr

    All other Seagate drives I have in enclosures never did this. I never use any of their software. When I get a new drive that stuff is trashed and I simply format.

    I do use bare drives in situations like recording and samples. I use these drives that come in enclosures for making archive copies of my stuff. Funny though, I do wind up buying external enclosure drives because for some reason they're much cheaper than the same size generic drive in its bare form, lol.

    Thanks again!
     
  10. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #10
    Also, it has made me wonder if maybe some of my seagate drives formatted years ago had these allocations and I was never aware since my older OSX's formatted with no issue.
    I plugged one into my windows laptop. I'm using MacDrive BTW.

    Sure enough it shows me an EFI allocation as well as a 128mb unallocated section. This concerned me but googling led me to understand the all drive formatting places these items on a drive therefore normal afaik.

    So the problem I had was apparently this 'microsoft reserve' EFI thing seagate apparently places on this version they market as 'expansion plus'.... one of many of their ways and names they market their drives, lol
    Seagate, you want to place s#@t software installers on your drives, fine, they can be trashed....but leave the other stuff alone, lol
     
  11. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #11
    Yes, in macOS the EFI partitions are used for staging firmware updates.

    From Wikipedia, “On Apple–Intel architecture Macintosh computers, the EFI partition is initially blank and not used for booting. However, the EFI partition is used as a staging area for firmware updates.

    The system will still boot after the EFI partition is deleted, in which case the boot manager will allow users to choose whether to start a Boot Camp partition or the default Mac OS X, but firmware updates will fail.”
     
  12. slinket macrumors newbie

    Joined:
    Feb 6, 2018
    Location:
    Australia
    #12
    --- Post Merged, Feb 6, 2018 ---
    Hey just found this thread hope someone has resolved this issue, purchased a Seagate 4tb Expansion drive, however have been unable to format on MacBook Pro running High Sierra 10.13.1. Purchased at Officeworks on the basis that they advertised that it worked with Mac.
    When you look at the Seagate http://knowledge.seagate.com/articl...S&key=ka03A000000Q0SEQA0&kb=n&wwwlocale=en-us its not really helpful as it simply says that this drive does not have any software.
    I did go to the Seagate site to find instructions for formatting or at least enough information to know if this drive is not compatible so I know if I should return the drive.
    Any ideas? Any suggestions? Like return it and get (brand) + ( model) alternative
    Thanks
     

Share This Page