New SL installation: Can't wake display on iMac

Discussion in 'Mac Basics and Help' started by yojitani, Jan 23, 2010.

  1. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #1
    The last computer in the house to have SL installed and I have a problem! This is a 20" White iMac C2D 2.16. The problem is that I installed SL and the 10.6.2 update (though I did do it through software update) today and since then I have not been able to wake the display from sleep. Actually, the display does not enter screen saver mode. Instead it hangs on a black screen that I can't get out of. I have to do a hard restart in order to get back in!

    I have done an SMC reset, I've reset PRAM, and I've fixed permissions all to no avail. Help!
     
  2. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #2
    Sounds like a failed logic board to me. Is the white light on when the monitor is off?
     
  3. yojitani thread starter macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #3
    Unlikely since this problem started when I installed SL. After posting this I changed the screen saver from one that randomized iphoto pictures to the standard SL one and it seems to be helping. It seemed that the transition into the screen saver is where the problems started so we'll see how much this helps.
     
  4. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #4
    Yeah I was going to mention that but forgot to. I think originally I didn't understand you problem correctly, but now I do.
     

Share This Page