New Snow Leopard download warning / quarantine driving me crazy

Discussion in 'macOS' started by seanmcgpa, Sep 28, 2009.

  1. seanmcgpa macrumors newbie

    Joined:
    May 12, 2008
    #1
    “*****.nzb” is an application downloaded from the Internet. Are you sure you want to open it?

    I get this message every time I download an .nzb file in Firefox with Snow Leopard.

    Yes, I know what an .nzb file is , and I know it's safe. Anyone know how to disable this warning on Snow Leopard? The 10.5.8 way of disabling this message doesn't seem to work.

    Anyone know?

    Thanks
     
  2. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
  3. BrianKonarsMac macrumors 65816

    Joined:
    Apr 28, 2004
    #3
    try answering his question, *THAT* would be much better :apple:

    @OP: I don't know, but it sounds annoying... like vista.

    lol... I searched in google briefly and came up with an article "How Do You Turn Off the Vista...err Snow Leopard Warnings?" sadly it was of no help other than posters telling the OP that's it not much of an inconvenience once he REALIZES their value! weird... Apple truly has some diehard fanboys that have no problem defending ANY "feature"
     
  4. seanmcgpa thread starter macrumors newbie

    Joined:
    May 12, 2008
    #4
    If Safari had adblock and the other Firefox extensions that I use, I would use Safari all the time.
     
  5. jcbatz macrumors newbie

    Joined:
    Oct 28, 2009
    #5
    Quarantine

    I'm getting the "this application was downloaded from the internet, are you sure you want to open it" every time I LAUNCH Firefox. How do I get rid of it? Is Snow Leopard really going to do this for every app that I download?
     
  6. cerberus 12 macrumors member

    Joined:
    Nov 13, 2007
    #6
    @OP yes, i find this "feature" exceeding annoying. I read a way to disable this feature is Leopard but I've been unable to find it over at MacOSXhints. Basically, create a script that runs as a folder action anytime a file is added to your downloads folder that removes the meta-tag that is used to identify a file as having been downloaded.

    If anyone knows how to do this, some help would be awesome.

    @The Trolls... go celebrate your browser of choice in a separate thread.
     
  7. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #7
    In Terminal:

    Code:
    xattr -w com.apple.quarantine "" /path/to/file
    This is how you remove the warning.
     
  8. cerberus 12 macrumors member

    Joined:
    Nov 13, 2007
    #8
    Thanks! How can I set that up to be attached to a folder option?
     
  9. larryy macrumors newbie

    Joined:
    Nov 7, 2009
    #9
    anyone have any success?

    Here's the link to a solution involving a magic .plist file that some people claim is working for them:

    http://mymacinations.com/2008/02/06/changing-the-systems-default-settings-for-html-files-safe/

    But I created this file -- actually just added "nzb" after the "amz" entry that was already present in this file, due to Amazon's use of this technique, apparently -- and it doesn't work with Safari or Firefox, even after a reboot. Here's a link for the same technique that excludes specific categories of files, but I don't have any more hope for it working than the above did:

    http://meyerweb.com/eric/thoughts/2009/03/13/disabling-downloaded-file-warnings-in-leopard/

    Here's the link to a folder action AppleScript that is supposed to work as long as your downloads all go to the same folder:

    http://henrik.nyh.se/2007/10/lift-the-leopard-download-quarantine

    But there are problems with frequency of checking for folder actions and I don't really want to disable quarantining altogether, just for files that are not actually executables. And I've seen people reporting that this doesn't work after a certain Leopard release anyway, though that may be down to timing problems, dunno.

    I'm almost as tired of researching a solution as I am of hitting my head on this stupid warning. Quarantining of executables makes sense. Quarantining of data files doesn't. This is one of the most annoying and Windows-like things Apple has done in a long time. Anyone have a solution for this that actually works reliably in the latest Leopard and Snow Leopard?
     
  10. larryy macrumors newbie

    Joined:
    Nov 7, 2009
    #10
    success!

    Okay, I got it to work. I was so frustrated and tired of working on it that I tried three things at once, so I can't say with absolute certainty which one (or which combination) worked, but I have a theory. If someone tries just that one thing and it fixes things for them, maybe they'll post and we'll have a minimal solution. The things I did were, in the order I think is likely to be responsible for making it actually work:

    * I opened the magic .plist file (described in the mymacinations.com article and previously edited by me and created by Amazon, in my case) in BBEdit (though I'm sure the great and free TextWrangler would do), did a "Save As...", clicked "Options...", and changed the "Encoding:" menu selection from "Unicode™ (UTF-8, no BOM)" to "Unicode™ (UTF-8)". Clicked "OK". And saved over the original version of the file, authorizing its replacement when asked.

    * I added all of the "LSRiskCategoryContentTypes" data from the meyerweb.com listing to the "LSRiskCategorySafe" key (as opposed to the "LSRiskCategoryNeutral" key used there), by just copying from that web site and pasting into the magic .plist file in BBEdit. (I also fixed the indenting.)

    * I copied this file into the all-users /Library/Preferences directory (as well as leaving it in the personal ~/Library/Preferences directory).

    Upon *reboot*, both Safari and Firefox no longer quarantine .nzb files. Hip hip hooray!

    I am fairly certain that only the first of those three steps is needed, for three reasons. First, I read of others who have had trouble with the .plist solution not working until they changed the file encoding. Second, some users have commented on the meyerweb.com site that the fix didn't work for them, so having just those content-type specifications doesn't seem to be enough, if there is some other problem (like file encoding). And I've read multiple times that ~/Library/Preferences is the correct place for the file, not /Library/Preferences.

    So I think all you have to do is create or edit that .plist file, and save it as "UTF-8" instead of "UTF-8, no BOM". And reboot.

    P.S. Even though I used the "LSRiskCategorySafe" key instead of "LSRiskCategoryNeutral", I suspect "LSRiskCategoryNeutral" might be the better choice, if you like to have "safe" files opened automatically. Well, unless you want all these different file types and files of specific extensions automatically launching apps and such. I have further processing of safe files turned off, so it doesn't matter for me, but if, for example, you like having your .dmg files automatically mounted when you download them, so you leave safe file processing on, you might prefer to add all the new stuff to the "LSRiskCategoryNeutral" key instead of the "LSRiskCategorySafe" key.
     
  11. macrem macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    #11
    Wow this is a Windows-like feature. I have been looking at several XML files which I downloaded from my webapp as a single zip file. OS X unzipped the XML files automatically without asking, then when I open XML files, each one has to be individually approved.

    Why Apple :confused:

    I came across this thread thinking I'd find an easy solution, but it does not look easy to eliminate this warning for non-executable files. I hope Apple is aware they went overboard & fixes it.
     

Share This Page