New Spotlight not working

Discussion in 'OS X El Capitan (10.11)' started by rduffy39, Sep 30, 2015.

  1. rduffy39 macrumors newbie

    rduffy39

    Joined:
    Sep 30, 2015
    Location:
    Basking Ridge / Philadelphia
    #1
    The new El Capitan spotlight search isn't working for me. It works just as it did on Yosemite. I type "weather" and spotlight wants me to open the weather channel app. I am connected to the internet, and I have everything possible checked off in the Spotlight section in System Preferences.

    Thanks all!
     
  2. alperduran217 macrumors member

    alperduran217

    Joined:
    Mar 24, 2015
    Location:
    Istanbul
    #2
    I have the same problem. I think it's about different language. My El Capitan is Turkish in the web page about the features of El Capitan they aren't mentioned spotlight features. What is your language of El Capitan?
     
  3. gabz90 macrumors newbie

    gabz90

    Joined:
    Sep 30, 2015
    #3
    My language is English (US) and I have the same problem, spotlight behaves just as it did in Yosemite
     
  4. omzie macrumors newbie

    omzie

    Joined:
    Sep 30, 2015
    #4
    Buddy goto system preferences, click on spotlight, uncheck all the fields including the one at the bottom that says Allow spotlight suggestions, then check it all back again and your spotlight should be working fine on El Capitan.
     
  5. oeyvind macrumors member

    Joined:
    Apr 20, 2002
    #5
    is this thing region specific? I can't get it to work since public beta... :(

    My OS langauge is US English, but weather does not work, nor natural language search works.... I'm in Singapore BTW.
     
  6. mactumors macrumors 6502

    Joined:
    Aug 3, 2008
    #6
    You have to type: "weather [city name]". Yeah, it's dumb.
     
  7. Te0SX macrumors member

    Te0SX

    Joined:
    Jul 29, 2014
    #7
    Lol mine too. Is just the Yosemite spotlight....first time I didn't make a clean install and boom...at least everything else run perfect. (As an alfred user, I can wait for an 10.0.1 to fix it)
     
  8. ed. macrumors member

    Joined:
    Jan 31, 2008
    #8
    Hi all, I am experiencing some problems too with the new spotlight, and I think I've found something interesting. I was running the iOS 9 GM on my iphone 5s and spotlight suggestions were working fine. Same thing on my macbook with the GM El Cap beta. Then I've installed the official release on the iphone and spotlight suggestions stopped working... while on wifi! Strangely enough they work fine when I'm on cellular.
    Today I've updated my other machine (an iMac) from Yosemite to El Cap and spotlight suggestions as well as natural language input didn't work while on wifi. Inspired by the weird iPhone "bug" I've then connected the iMac to the internet through the iPhone on cellular via the hotspot function, and boom: spotlight suggestions started working properly on the iMac: web and wikipedia results, natural language and so on.
    The weird thing is that I have this strange malfunction on an iPad, iMac and iPhone, while the macbook works fine even on wifi.
    Maybe all of you who cannot make this work can do this quick test and check if the cellular connection suddenly makes spotlight suggestions work.
    BTW For anyone who's keeping score: I'm located in Germany but my language and region settings are Italian and Italy.
     
  9. thekayman macrumors 6502

    Joined:
    Oct 23, 2014
  10. Rub3n NL macrumors newbie

    Joined:
    Oct 1, 2015
    #10
    Same here... It seems to be very erratic. Sometimes it does return the right results, and sometimes it doesn't.
    It doesn't show any photos. I tried to create a new spotlight index. Now it's a bit better. But not even close to what was promised.. Whether forecasts do show up sometimes...
    I want my money back!;-)
     
  11. ed. macrumors member

    Joined:
    Jan 31, 2008
    #11
    Hey I solved it! the problem is not the wifi, but the DNS settings: for some reason my ISP (Deutsche Telekom) is blocking the queries for the online stuff: on my laptop I have Google's DNS (8.8.8.8 and 8.8.4.4) and that's why it worked.
    I have now set them up on the iMac as well and I get wiki results and natural language as well.
    It does not seem to give decent results from the photos app, though, and I have to understand better how that works.
     
  12. oeyvind macrumors member

    Joined:
    Apr 20, 2002
    #12
    Changed DNS to 8.8.8.8, even reset Safari search engine to Google... yet nothing works :(
     

    Attached Files:

  13. Rub3n NL macrumors newbie

    Joined:
    Oct 1, 2015
    #13
    Tried the DNS thing, did not change it for me
     
  14. Tankmaze macrumors 68000

    Tankmaze

    Joined:
    Mar 7, 2012
  15. originalmagneto macrumors member

    originalmagneto

    Joined:
    Jun 7, 2015
    Location:
    Slovakia
  16. muhammadali__ macrumors newbie

    muhammadali__

    Joined:
    Oct 20, 2015
    #16


    https://www.apple.com/osx/feature-availability/


    Check here. it answers all your questions.
     

Share This Page