New SR MBP doesn't connect to WPA networks?

Discussion in 'MacBook Pro' started by powerocool, Jun 6, 2007.

  1. powerocool macrumors 6502

    powerocool

    Joined:
    Jun 5, 2007
    #1
    Ok, I just started setting up the new MBP 2.4G Glossy. Here's something strange:

    I could connect to my current wifi with WPA (which works fine on my 1st gen. MBP), but when I launch Safari, no web page would show up.

    So, I switched to WEP and it worked. Anybody can confirm this?

    (I've tried WPA, WPA2, WPA+WPA2, all fails to load web pages. The router is a Netgear WGT624 v3)
     
  2. beej69 macrumors member

    Joined:
    Nov 22, 2003
    Location:
    Puerto Rico
    #2
    Ack

    wow. glad i found your post. i was pulling my hair out with the same problem with the same router and latest firmware and a brand new C2D blackbook that came running the b/g/n driver. i ended up just turning encryption off. no point in fooling myself with WEP. google for "wep ptw" if you don't know just how broken WEP is.

    here's what my router claims to be:
    Account Name WGT624
    Hardware Version V3H1
    Firmware Version V1.0.128_1.0.1

    if i have the energy, i'll bug netgear, but it's unlikely ;)

    thanks again!
    marc
     
  3. computerman-8 macrumors member

    Joined:
    Oct 11, 2007
    #3
    My new MBP is connected via WPA2 and it works fine. Must be the router. I would start by giving Apple a call and maybe they can do some troubleshooting.
     
  4. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #4
    My Santa Rosa MBP connects to WPA networks. I don't now why yours does not. :confused:
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    Likely nothing wrong with the computer, Netgear tends to be problematic with Macs these days.

    Sort of sucks, because years ago they were the supplier to go to if you had a Mac.

    ---

    Almost to the point now, that if people are having network router issues with Macs, you'll probably find a Netgear product there.

    Edit:

    You can always check here to see if there is a solution

    http://forum1.netgear.com/
     
  6. four2err0r macrumors newbie

    Joined:
    Oct 13, 2007
    #6
    oo

    Yes my SR MBP 17 glossy 2.4 works fine with WPA also, I had to do nothing! Those guys are right too, but you should try getting rid of ****** safari and move to mozilla!
     
  7. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #7
    Mine works fine with WPA2, and I'm using a NetGear Router and an Airport Extreme Base Station.

    Whilst I'm on, my vote goes to Mozilla Firefox too - it's like a breath of fresh air!
     
  8. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #8
    Has anyone here with the severe wireless problems tried the switch to Linux Firmware?
     
  9. thegrandmaster macrumors regular

    thegrandmaster

    Joined:
    Feb 3, 2007
    Location:
    Valhalla!
    #9
    Forget Firefox! Use Camino! Its got all the Mozilla goodness that Firefox does only in a more 'Maccy' way. Unless you desperately want extensions, try Camino instead, I found it to be stabler and faster than FF.

    I've never experienced any problems with WPA on my MBP, I've used it on my WPA protected network at home and where I'm living at the moment without any issues.

    I hope your issue gets resolved soon! :)
     
  10. beej69 macrumors member

    Joined:
    Nov 22, 2003
    Location:
    Puerto Rico
    #10
    err.. the WGT624 (which this thread is about, not WPA in general) doesn't use a broadcom chipset and can't (yet?) run dd-wrt. that was the first thing i would have tried otherwise :)

    to everybody else: nobody is claiming that there are any hardware issues. obviously there is some subtle bad interaction between netgear's WGT624 firmware and apple's/broadcom's firmware/software in the pre-santa rosa C2D macbooks. there's no point in trying to blame one or the other until somebody has conclusive evidence of who is actually at fault. and i don't care enough to make that happen :)
     
  11. compuguy1088 macrumors 6502a

    compuguy1088

    Joined:
    Sep 3, 2007
    Location:
    In the Sub-Basement of Solitude
    #11
    Everything but the wonderful thing called Extentions. I personally want to still have my NoScript and AdBlock.....
     

Share This Page