New SR MBP - screen black after iSight shot

Discussion in 'MacBook Pro' started by amitface, Jun 25, 2007.

  1. amitface macrumors regular

    Joined:
    Jun 18, 2007
    Location:
    Florida
    #1
    My 15" SR MBP arrived today, and it's been awesome. No problems whatsoever, until later in the day I tried using iSight for the first time. When I snapped the photo, it went "3 2 1:" and the screen went black. i couldn't do anything. I had to take out the battery and put it back in. When I restarted, the reboot was taking forever. It never got past the apple logo on the white background. So I took out the battery again and rebooted. Now it works fine, as does the iSight.

    Any ideas?
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Open Disk Utility and verify the Hard Drive. It sounds a lot like something happened to the hard drive when it took the picture.
     
  3. mikeymike88 macrumors member

    Joined:
    Jun 19, 2007
    #3
    Mine did that too once. But it didn't actually turn completely black, it just lowered the brightness too the lowest setting. I turned up the brightness and everything was fine. It was weird though and I still don't know why it happened. Hope this helps.
     
  4. quik macrumors regular

    Joined:
    Apr 8, 2005
    Location:
    Montreal (Canada)
    #4
    It did the same thing!

    I didn't thought about the brightness but my GF said "Hey it's just the brightness" when I was rebooting...

    Weird! But photo was taken :)
     
  5. amitface thread starter macrumors regular

    Joined:
    Jun 18, 2007
    Location:
    Florida
    #5
    Sorry, I'm new to Mac. When I open Disk Utility, I can't Verify Disk or Repair Disk. It only lets me verify and repair permissions.

    What do I do??
     
  6. Trepex macrumors 6502a

    Trepex

    Joined:
    Apr 5, 2007
    Location:
    Ottawa, Canada
    #6
    could it be the ambient-light sensor dropping the brightness because of the flash of light???
     
  7. L3X macrumors 6502a

    Joined:
    Oct 18, 2006
    Location:
    Chesapeake, VA
    #7
    excellent point. turn off of the ambient light sensor. The screen probably just dimmed to where you couldn't see anything.
     
  8. Alloye macrumors 6502a

    Joined:
    Apr 11, 2007
    Location:
    Rocklin, CA
    #8
    I noticed this when I first opened Disk Utility on both of my MBPs. It seems Apple forgot to enable disk journaling on these machines. I took care of it by selecting the volume and then clicking the Enable Journaling icon in the toolbar. After that, I was able to verify the disk.
     
  9. thegrandmaster macrumors regular

    thegrandmaster

    Joined:
    Feb 3, 2007
    Location:
    Valhalla!
    #9
    My iBook's screen sometimes goes totally dark, not off, you can just about see it, but its like the backlight has been switched off. Sometimes putting it to sleep fixes it, other times I have to restart. Doesn't happen very often though.
    Weird stuff. :eek:
     
  10. Hard-Hat-Mac macrumors regular

    Joined:
    May 18, 2007
    Location:
    Philly Burbs
    #10
    This has happened to me twice now. once when I was using it in my dim lit living room and another when my wife was using it during the day in our brightly lit computer room.

    Have we confirmed that it is just the ambient light sensor going bonkers or is it something more? It's not too hard to remedy just brighten up the screen manually but it is annoying when it does happen.

    Any thoughts besides turning off the ambient light sensor? I really like the auto glow key board.
     
  11. sxl95 macrumors member

    Joined:
    Nov 7, 2006
    #11
    You can still have the keyboard light up, but disable the automatic brightness. This is something I needed to do to make my machine usable, because it seemed to adjust the brightness while I was typing when the automatic brightness enabled, which was very annoying.

    And when it comes to annoying:

    If I want an annoying computer, I'd buy something with Windows. Luckily, the automatic brightness is super easy to turn off! :)

    -Sam
     

Share This Page