New SSD disk misbehaving

Discussion in 'Mac Accessories' started by dantastic, Aug 8, 2013.

  1. dantastic macrumors 6502

    dantastic

    Joined:
    Jan 21, 2011
    #1
    I have just got a Crucial M4 SSD disk to go in my old enough imac. I also have a cheapo ebay powered USB to SATA converter cable jobby.

    Being a lazy git I wanted to clone my old disk over to the new one with carbon copy cloner and be done with it.

    I plugged everything in, the new disk showed up in disk util, I partitioned it and I left it just sit there while I was doing other things. All of a sudden a popup saying the disk was not clearly unmounted. didn't think much more of it at the time.

    I came to cloning, was struggling a getting the computer to connect to the disk, I had to leave it unplugged completely for a minute or so before reconnecting for the disk to actually connect and show up in diskutil.

    Anyway, got it connected and started the cloning using CCC. Came back an hour later to check the progress, again it said it had been improperly disconnected.

    Doing a bit of a dance with the disconnection and reconnection, after a few tries it would connect the disk and I could try again. Saw that only 3 GB made it across the first go. Started again and monitored this time, just over 3 GB made it across before the disk disconnected.

    Again a bit of a wiggle but I disconnected the drive for a while and connected it again, this time the OS said I had an uninitialized drive that needed formatting. Not too pushed about that I sad, go ahead, format!

    Unable to create partition, cant write to the last block (something like that).

    Since then the disk does not even show up in diskutil anymore, no matter how hard I try.

    I have taken the disk and the cable with me to work and I'll see here if I can test the USB cable against a known good disk and the disk against a known good cable.

    Do the panel have any suggestions though?
     
  2. dantastic thread starter macrumors 6502

    dantastic

    Joined:
    Jan 21, 2011
    #2
    Have tried again now on a different computer and with a different hdd.
    so the USB cable thing is fine.
    then tried again with the new SSD disk, it's still failing so it seems to be the disk.
     
  3. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #3
    It sounds like the SSD as you said, but I am wondering if you should try another install method such as Time Machine? You can just plug in your TM drive and the Mac will boot from that. Then format and install from your TM backup.

    Or try internet recovery by holding down CMD Option R on start-up. Then install from the TM drive.

    I doubt the above will work, but at the very least it will confirm even more it is the SSD if it does not work.
     
  4. dantastic thread starter macrumors 6502

    dantastic

    Joined:
    Jan 21, 2011
    #4
    All of that assumes the thing is recognizable by the computer. If the computer cannot even see the disk we're pretty fooked...
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
  6. thedeske macrumors 6502a

    Joined:
    Feb 17, 2013
    #6
    Agree - el-cheapo = el-disconnecto
     

Share This Page