New SSD + Leopard install fine | Error Installing Snow Leopard

Discussion in 'macOS' started by .jayun., Sep 24, 2010.

  1. .jayun. macrumors newbie

    Joined:
    Aug 29, 2009
    #1
    (Forgive me if this is in the wrong section. My issue may cover several sections. A moderator can move it where they see fit.)

    My setup before was a 13" MBP (August 2009) w/ Leopard installed. Snow Leopard came out soon after and I purchased the $30 upgrade disk. I then immediately installed Bootcamp and Windows 7. Everything has been running flawlessly since.

    I just purchased an SSD to replace the 250GB HDD that came in the MBP. I don’t desire to image anything – I’m fine with starting fresh. I had nothing on my OSX partition except for CS4 – I rarely used it. The Bootcamp partition with Windows 7 I can rebuild in less than an hour, so it’s not a problem.

    I put the SSD in last night and attempted the install of OSX Leopard via the DVD media included with the purchase of my MBP. The SSD was found right away – the proper size, I formatted it, enabled Extended Journaling, fine.

    At first, I tried installing Snow Leopard straight up using the disc I purchased from the Apple store. That didn’t work – it kept failing at the 28minute mark. I reset my PRAM and NVRAM. After lots of Googl’ing and no real solutions… I reasoned that the issue was with using the upgrade disc and not an original install disc? (no forum posts suggested this though). So I used the Leopard disc that came with my MBP. It took a little longer than I thought it would take.. but it eventually worked. I then ran Software Update and got all the available updates for Leopard. Leopard was working fine – quite fast too.

    While logged into Leopard, I began the install of Snow Leopard using the upgrade disc I purchased from the Apple store in August of 2009. The install process said it would take 1.2 hours. It failed at about 30 minutes into the install. It was late, so I tried again and let it run overnight. This morning I woke up to another failed install. (I have the log file saved on the desktop, which I’ll look through more thoroughly and post back here when I get home from work.) I’m hoping someone recognizes something I’m doing wrong before it gets into logs files and troubleshooting.

    The Apple Store ‘Genius’ said that the Snow Leopard disc can be used multiple times.

    The disc doesn’t appear damaged – it was only used once to upgrade my MBP last Fall.

    I don’t ever use my DVD drive.

    Any ideas?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Even if the disc looks fine, it's certainly possible it's a bum disc and/or there's something wrong with your drive. The former seems unlikely since it worked once a while ago, and the latter since you just managed to install 10.5 without issue, but one never knows--particularly if the 10.6 disc was marginal to start with and you got lucky last time. Have you tried turning off all the optional installers (printer drivers, languages)? Maybe you avoided the "bad" spot last time because something optional didn't get installed.

    I've read about a handful of people having trouble getting the OSX installer to recognize new SSDs, but if 10.5 had no issues it doesn't seem like that's the issue. The test would be to see if you can install a fresh copy of SL onto another drive (either external or put the non-SSD in); if that works, then you could use CCC to copy it to the SSD and should be good to go. If that also fails, must be either the disc or the computer.

    I've only installed SL once so far, but older OS installers did a pre-check of the disc to make sure there were no problems reading it--anybody know if SL still does this? You might try using Disk Utility to create a disk image of the installer; if it hangs partway through or complains of read errors, that'd confirm a bad disc, though a finished image doesn't guarantee there's nothing wrong with the disc (might just be imaging bad data).

    And no, Apple currently does no sort of copy protection at all when it comes to consumer OS installers (Server has a serial key), so it's not some sort of too-many-installs issue like plagues Windows. (That alone would have me buying Apple products even if I though they were slightly inferior to Windows--the number of pointless hours I've wasted on Windows DRM during completely legit activities is depressing.)
     
  3. .jayun. thread starter macrumors newbie

    Joined:
    Aug 29, 2009
    #3
    I received a new OCZ Vertex 2 SSD yesterday. It came with firmware 1.22. I immediately installed OS X 10.5.7 from the DVD that came with my Mac - that worked fine, as always. I then proceed to upgrade to Snow Leopard 10.6.3. It got about 15 minutes in and the system prompted for new updates. I did nothing and the system automatically restarted. After some hesitation, it booted back into the installer and showed 34minutes remaining - while the spinning rainbow cursor was happening. I left it alone for the night and came back this morning to a failed installation, again.

    While it did appear to get further this time around, it still doesn't work.

    This is so aggravating.
     
  4. 3282868 macrumors 603

    Joined:
    Jan 8, 2009
    #4
    Sorry to bring back an old thread. I was having this exact issue. I reinstalled "Snow Leopard" on my OCZ 120GB Vertex 2. The first installation went well but I needed to reinstall due to another unrelated issue. I was met with the failed installation at the 28 minute mark numerous times.

    I learned that previous incomplete installations can still hinder the future installations even if the SSD is partitioned/erased in "Disk Utility". The error was resolved by zero-out erasing the Macintosh HD partition before installing "Snow Leopard". I don't know the reasons why this is important, perhaps there is data written to the MBR from incomplete installations that requires a zero-out erase. Any ideas?
     
  5. woodbine macrumors regular

    woodbine

    Joined:
    Aug 8, 2010
    Location:
    Bath, UK
    #5
    me too!

    I am having terrible issues getting SL to install on my OWC Extreme. Very similar to other posters, it seems to run 'ok' then I come back and the screen is blue with the beachball.
    When I can eventually look at the SSD, all I see is a folder of install pkg's.
    I am also coming to the conclusion that the install disc doesn't like the SSD.
    I have on an external drive, a clone of the original SSD and a fresh 10.6.8. If I boot off the external, it's hit and miss whether the SSD will even be visible. I have looked at system profiler and sometimes it is there, sometimes not.
    Just don't know what to do!

    If I take the route of installing of the restore DVD to my external drive, will that be a suitably configured OS that I can clone back to the SSD?
     

Share This Page