New SSD slow wake up

Discussion in 'MacBook Pro' started by schpongo, May 17, 2014.

  1. schpongo macrumors member

    Joined:
    Feb 21, 2011
    #1
    Hey guys

    I recently bought a new ssd. I now have a 480GB ssd compared to my previous 120GB. I also have 16GB of ram.
    I have quickly noticed that with my ssd (a faster ssd) the wake times have gone up. Even if i just close my lid for 1 min my laptop takes about 30 seconds to become responsive ( that should roughly be the time it take my ssd to read a 16GB hibernation file) .
    I have read about the standby times. But I don't think that is my problem, as I already changed my "standbytime" to 5 hours.

    I would like to solve this problem because with my smaller ssd my macbook pro had an instant wake up.
     
  2. HCR93 macrumors member

    Joined:
    Dec 21, 2011
    Location:
    Manchester, UK
    #2
    I had the problem ages ago with my Crucial M4 512GB in a 2010 MBP... slower to wake than the old HDD I had it there before! I think for me it took an OS X update to fix the issue (I know that really isn't much help, sorry).

    Did you do a clean install, clone the old image, or restore from backup onto the new SSD?

    Also what SSD have you moved from and to?
     
  3. schpongo thread starter macrumors member

    Joined:
    Feb 21, 2011
    #3
    Thank you for your reply.
    I did not do a clean install as my last clean install had not jet been a year old.
    So I just did an image copy.
    I moved from an OCZ Agillity 3 120GB to a SanDisk Extreme II 480GB.
    I think I could fix the Problem with a fresh install but that's not really a clean and targeted solution.
     
  4. HCR93 macrumors member

    Joined:
    Dec 21, 2011
    Location:
    Manchester, UK
    #4
    Not really sure what to suggest beyond a clean install (I know they're a hassle). I'm a bit over-zealous about them, still stuck in the Windows mentality of doing them semi-routinely I guess...

    Have you tried a different user account to isolate if it's just your profile? And the standard permissions check/repair (I know everyone always jumps to do that). Is the SSD recognised in system information at full speed SATA III? Any other modifications (like enabling TRIM)?

    Beyond that, I'm stumped really. As I say, my issue disappeared with an OS update but that's not really a satisfactory answer I know...
     
  5. thundersteele macrumors 68030

    Joined:
    Oct 19, 2011
    Location:
    Switzerland
    #5
    I've had a similar issue with my Samsung 830. One of "resetting SMC" or "resetting PRAM" fixed it I think.
     
  6. schpongo thread starter macrumors member

    Joined:
    Feb 21, 2011
    #6
    So I did some more googling and it turns out to be a specific problem with my SSD.
    There seems to be a software Problem between the operating system and the ssd firmware which causes the delayed wake up.
    According to reports of other users who have contacted sandisk, sandisk and apple are working together to fix the problem.

    As of writing this post there seems to be no solution for the Problem.
    So one can either wait or buy a new ssd.

    Thank you for all your help
    Greetings form Germany
     
  7. ivaren macrumors newbie

    Joined:
    Feb 8, 2014
    #7
    sandisk has now releases a firmware fix for this. Finally!
     

Share This Page