New System Hard Drive OS 9 problems

Discussion in 'Mac Basics and Help' started by Andy B, Feb 17, 2006.

  1. Andy B macrumors newbie

    Mar 12, 2004

    Apologies if this is the wrong place to post this.

    I have an old G4 400 and its System drive died yesterday.
    I went out and bought an Excelstor IDE 40gig drive and fitted it, initialized it (extended) and tried to install from the original disc that came with the machine - OS9.0.2. It was then my plan to get it back up to 9.2.2 online.

    Although it said the installation was successful and it took me through the general setup, I can't open any applications (apart from the calculator!). When I try to open an application it tells me that it can't find it because the 'PMULib' can't be found. if I try to go online it starts IE and runs the Internet first run in an endless loop.

    It's also trashed the System Resources and on startup it tells me it can't start the AirPort assistant setup.

    Finally when it's been idle for a while it gives me a System Error -2806 message and forces me to reboot. I've done a search online for this error, but found nothing.

    I've reinitialized the drive and reinstalled the OS three times with the same result. I can't say if it's drive related, but I've just looked at Get Info and in the Comments window it says 'Z694-1231' which seems a bit strange to me that it says anything?

    Can anyone suggest a way of getting this machine up and running again?

    Thanks in advance,

  2. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    Whoa.... strange errors

    Are you sure the Mac OS 9.0.2 restore CD is an original Power Mac G4 restore CD? Or could it be a restore CD belonging to another Mac (i.e. iBook orso), resulting in a slightly different installation of System files.
    Must admit though, that installing a newer Mac OS 9.x restore CD on an older Mac ususally doesn't result in errors.... but maybe in this instance...

    I wonder what the PMUlib is. Probably a System Extension. Power Management Unit library...??
    Could you get hold of a "generic" Mac OS 9.1 CD? Or maybe a later G4 Power Mac restore CD with Mac OS 9.0.4 on it?

Share This Page