New TB Macbook Pro minimize windows slow?

Discussion in 'MacBook Pro' started by MarcBou, Dec 8, 2016.

  1. MarcBou macrumors regular

    Oct 11, 2016
    So last night I got my 15" new MBP and I'm loving every part of it. Just have one concern, I didn't have much time to test it out, but I noticed that when I make the windows smaller or bigger (in Chrome, Safari, Finder, etc,) by double tapping or pressing and dragging, the movement is not smooth, at least not as smooth as it should.

    This is my first Apple machine, so I really don't know how it should be, I've worked with iMacs and old macbooks Pro at work but never really paid attention to this.

    My machine has 2,6Ghz and Radeon 460, 1Tb SSD. I wasn't doing anything heavy when I tried this, just had couple of tabs open on safari. I'm not sure if I just tried this without the power cable connected, but anyway, this shouldn't happen even if it's not connected.

    Any thoughts about it? Is this normal? It may just happen sometimes? I just test it for an hour or so.

    In spite of this I love this machine.

  2. dark_mark Suspended

    Nov 5, 2016
    Yes it's a known issue on new macbook pros. It's due to very weak iGPU. There are many people reporting this:
  3. jpeezy macrumors regular

    Feb 24, 2010
    Sorry but this is wrong. The lag still exists even switching to the dGPU. This is a product of terrible optimization in Sierra. I have a late 2015 5k iMac that has this same issue, once I upgraded to Sierra. El Capitan was fine.

    If you read through that thread, many people agree that this is a software issue.
  4. MarcBou thread starter macrumors regular

    Oct 11, 2016
    That makes more sense, would be really odd if this new machine couldn't handle minimizing windows with the iGPU...

    BTW, there's any way to change between iGPU and dGPU? Or it just does it automattically when needed?

    Thanks both for ur answers!
  5. jpeezy macrumors regular

    Feb 24, 2010
    The easiest is to download gfxCardStatus, which has better control. You can also disable auto switching in System Preferences/Energy Saver, this will use the dGPU.

Share This Page