New to Jaibraking, need help pls!

Discussion in 'Jailbreaks and iOS Hacks' started by bryter, Nov 24, 2010.

  1. bryter macrumors newbie

    Joined:
    Nov 24, 2010
    #1
    Hi All,

    I have an iPhone 3GS iOS 4.0.1 jail broken and unlocked. I would now really like to upgrade to iOS 4.1, but i am not really aware how all this is done (it was jaibroken by a friend of mine). Ive read many forums and posts related to JB, but most of those are only concerned with new iphones that come with 4.1 (from what I've understood at least). So my questions go like this:
    - When upgarding to iOS 4.1, do i need to backup everything that is in my iPhone? If i don't, will all my photos,emails...be deleted?
    - Should i update to 4.1 using iTunes? Or should i do it manually? In both cases, what are the exact steps that i should take?
    - From what ive read, there are many jailbraking apps for 4.1. From your experience, what is the best one?

    Thanks to anyone who can help :)
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2


    The best way to upgrade to 4.1 is using PwnageTool (Mac only). PwnageTool preserves the baseband so you can unlock on the new iOS. This is pretty much your only option.

    Right now Apple isn't signing 4.1 anymore as they released 4.2 and 4.2.1. Upgrading through iTunes would be a no-no.

    To jailbreak 4.1 you can use PwnageTool, Redsn0w, LimeRa1n or GreenPois0n. PwnageTool is the only software that allows you to save your baseband.

    4.1's baseband 5.14.02 is currently not unlockable.
     
  3. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #3
    Currently im on windows xp. So how to i upgrade to 4.1?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Find a friend with a Mac or find a custom ipsw created with pwnage on the internet.
    No other way around it without losing your unlock.
     
  5. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #5
    Upgrading to 4.2

    Hi guys,

    I am finally planing to upgrade to 4.2, mostly because of some apps that are working only with 4.2. I thing i finally know how to do it: i will follow the guides at this link:
    http://www.iclarified.com/entry/index.php?enid=12945

    My only remaining problem is related to unlocking. I have a baseband 05.13.04 and new bootroom 945. So i am not sure if i will be able to unlock using the latest version of Ultrans0w. Also i don't really know what baseband is; is it somehow related to the type of carrier? what are the consequences if you can not retrieve to an older baseband?

    Please see if you can help.

    Thank you :)
     
  6. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #6
    Base on your baseband (moderm firmware) is whether you can unlock with Ultrasnow or not. With 5.13 baseband, it can be unlock with Ultrasnow. As to having new bootrom, it means you will have a tethered JB on 4.2.1. Which means everytime the phone reboots, you must use Redsnow "tethered boot" option to boot up the phone otherwise you will be stuck at the "Plug into itunes" screen.
     
  7. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #7
    I jailbroke the phone, but now i am having problems unlocking it. It wont recognize the sim card (it just says "Searching...") although i installed ultrasn0w and restarted. Should i re-run redsn0w and use that iPad option to change the baseband to 06.15?
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    No, don't install the iPad baseband unless you really really need to. Whats your bb version now?
     
  9. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #9
    Edit: it is 05.15.04

    I also installed/reinstalled ultrans0w, reseted network settings, tried two sim cards, and still nothing.
     
  10. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #10
    Is there any other unlocking app that i could try?
     
  11. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #11
    Ultrasnow doesn't unlock 5.15 baseband.

    Nope.
     
  12. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #12
    Sounds like your only option to unlock now is to install the ipad BB.
    Up to you but you might lose your GPS function if you do that.
     
  13. wolfgang666 macrumors regular

    Joined:
    May 6, 2010
    #13
    seems like you shud have just stayed wit 4.0.1 coz there are rumors that the new JB and unlock will be released after the new iOS is out..
    so i would suggest just hang on for some-more time and use your phone as only an ipod unless you wanna take the risk and going upto the ipad baseband..
     
  14. bryter thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #14
    I changed the baseband to the iPad one using redsnow. So far GPS does not seem to work as well as before (it cant find my exact location). Other than that, i was able to unlock, and the iPhone is actually much faster than with 4.02. So i'm really happy.

    Thanks very much to you guys for your help! :)
     

Share This Page