New to Mac - problems with Audacity (Save As dialog mainly)

Discussion in 'Mac Basics and Help' started by ArthurDaley, Mar 30, 2008.

  1. ArthurDaley macrumors regular

    Joined:
    Feb 29, 2008
    #1
    Just switched to Mac (MBP).

    First application I am using is Audacity which is good as the interface is the same as the PC so not much effort to switch.

    But there are a couple problems.

    1) When I do a "Save As" and begin typing the filename the program (Audacity) takes this as keyboard shortcuts! I can not believe it! When using the Save As dialog box the program executes the keys I push as part of the filename as shortcuts - so by the time I have typed the filename it has recorded, edited and screwed up the waveform. Surely when a Save As dialog is open and you are typing a file name the system should shut off keyboard short cuts to the app? This is a nightmare.

    2) In the Save As dialog box generally, there seems to be no way to say with one click go back up one directory from current position - this is annoying.

    3) On the PC I like Zooming in with Left button and Zooming out with Right button, but it seems on the Mac since there is only one button I have to go to the menu to get the other Zoom which is annoying as it takes much more time.

    4) For export to MP3 I use the LAME plugin encoder. On the PC it is no trouble to get LAME but for the life of me I can not decipher where to get it for the Mac to plugin to Audacity.
     
  2. bartelby macrumors Core

    Joined:
    Jun 16, 2004
    #2
    Can you not use 2 fingers+click as right click?

    And for the 2nd Save As... issue:
    You can see the folder hierarchy from the drop down menu:
    [​IMG]
     
  3. ArthurDaley thread starter macrumors regular

    Joined:
    Feb 29, 2008
    #3
    No - does not seem to work. I guess something is misconfigured even though it is a brand new MBP. So I just bought a Logitech Revolution MX mouse so I now have a right click.

    Yes I can see the current folder as you describe but I see no easy way to say just go back up one folder (i.e. to parent folder). I find it common to have one directory and then many subs and depending on work I am doing, to knock it back up to the parent and down into another sub. But it seems on the Mac Save As you have no way of just saying quickly go up to the parent. On the PC you can just click one icon to say go up one folder in the Save As dialog box.
     
  4. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #4
    Hi,

    I think I have some solutions for you:

    Right click with 2 fingers
    Go to System Preferences > Keyboard & Mouse. Go to the Trackpad tab.
    Check the box, saying Tap trackpad using two fingers for secondary click.

    Folder hierarchy in Open/Save dialog
    As in Finder you can use command-1 to switch the dialog to Icon view, command-2 for List view and command-3 for Column view. You could also use the icon at the top of the Open/Save dialog.

    To go up one folder (independent of view), you can also press command-up arrow.

    Lame encoder
    Did you take a look at this FAQ entry on the Audacity site?

    Hope this is helpful to you.
    /Rupert
     
  5. roogie macrumors newbie

    Joined:
    Apr 19, 2008
    #5
    Arthur,

    It took a bit for me to figure out what was screwing up my sound files, but this is exactly what happened to me too! I can't believe the keyboard shortcuts work in the Save As.. dialog box.

    However, I did find in the preferences that you can edit each shortcut, so I removed every single instance of a shortcut that didn't utilize a modifier key (like Command, Option, Control, etc.) This has fixed the issue for me on my MBP.

    Enjoy,

    roog
     
  6. musicvortex macrumors newbie

    Joined:
    May 9, 2008
    #6
    Sorry to bump, but I experience the same problem with keyboard shortcuts in the save as dialog box. I love audacity, use it constantly, but this problem is incredibly frustrating, and I would have thought that they would have fixed it. Are they aware that this issue exists? If not, does anybody have suggestions for how we might be able to contact the developers and notify them of this ongoing issue...?

    EDIT: Great news! The issue seems to have been fixed in the beta version of audacity for mac (v1.3.6). they also redesigned the UI, and it looks amazing. love it!
     
  7. xefned, Jun 14, 2012
    Last edited: Jun 14, 2012

    xefned macrumors newbie

    Joined:
    Mar 18, 2010
    #7
    so bizarre

    It's so weird when people develop a program, yet are so disconnected from the user experience they don't fix bugs obvious to any actual user. Perhaps they only test it on PC.

    It's ****ing 2012 and this issue continues. I always thought they would fix this by now.

    It's not a Mac thing. It's an audacity thing. Audacity is the only program I've ever used on mac that does this... ****rz.

    -- on a positive note though, Thanks ROOG for the suggestion. Worked a nut.
     
  8. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #8
    Exactly what version of Audacity are you seeing a problem in? And exactly which problem: the "keys as shortcuts" problem or the "can't navigate with keyboard" problem?

    I use Audacity 1.3.14.0 and have never seen the "keys as keyboard shortcuts" problem. Maybe I just haven't used the right shortcut keys, though testing with Shift-J and [ ] show no problems.

    And 1.3.14 isn't the newest version. They've gone to 2.0.
     

Share This Page