New to PPC, having trouble with a Powerbook G4

Discussion in 'PowerPC Macs' started by jimstolz76, Oct 6, 2010.

  1. jimstolz76 macrumors newbie

    Oct 6, 2010
    Hey all,

    My step-daughter just got a hand-me-down Powerbook G4 that I swear looks brand new. It's obviously been used, but not much at all. Anyway, I'm stumped with a problem. I'm used to working on PCs, and the only macs I've worked with so far are Intel-based, so I'm totally flying blind here.

    Started having random issues. Programs closing themselves, running slow, Disk Utility would run endlessly with no progress, etc. After a few hours of running Disk Warrior and Drive Genius 2, I THOUGHT I had it fixed. I was able to repair the disk, and repair permissions, and after testing and retesting and retesting I got to the point where I was getting ZERO errors on anything. I put the 2nd RAM chip back in, ran some more tests and thought we were good to go.

    Then we got a kernel panic while she was using it today. OK, here we go again. Tried Drive Genius. Kicked back an error and said to restart. Tried Disk Warrior. Kicked back an error and said it couldn't be rebuilt. Umm ok. Now what? When you try to boot from the HD it just sits at the Apple logo with the spinning graphic below it. Finally after a while (5 minutes?) it just shuts down. It will do this every time.

    We don't have the original OS X install disk. I only have a 10.4 install disk from an intel iMac and I can't boot to that.

    I'm assuming the HD is dying --- OR that some of the RAM really is bad and it somehow jacked up something on the HD when she started using it. I wanted to run memtest86 from a linux USB stick but couldn't get it to work, then burned a CD of a PowerPC build of Ubuntu 10.04 and it just booted right in and didn't give me the option to run memtest...argh...

    If I go out and grab a Firewire cable and boot into Target Disk Mode from my intel iMac, will I be able to run Disk Utility to do verify/repair and maybe even repair permissions at the same time?

    I'm struggling here, and my step-daughter is really bummed that she can't use her "new" laptop..... I'd be bummed to... she was going from an Asus eeePC to a shiny aluminum Mac...even if it is a few years old. :)

    ANY help is greatly appreciated!
  2. PowerGamerX macrumors 6502a


    Aug 9, 2009
    Take out the ram sticks (or rather, take one out, leave one in) and see if that solves the issue. It sounds like the HDD is going bad, and they aren't fun to replace in PowerBooks.

    After you do it a few times, its easy, but the amount of screws is insane, but, as long as you keep track where each one goes, you should be fine if you decide to replace it.
  3. jimstolz76 thread starter macrumors newbie

    Oct 6, 2010
    Thanks for the info. I've tried booting it with 1 memory stick, but for some reason haven't tried booting with just the "other" memory stick. Right now I'm too tired to deal with those 4 microscopic phillips head screws on the memory cover. Seriously, what are they, #0000 size?? I'm using a jeweler's screwdriver and it's too big... WTF? LOL

    So I'm gonna try this:
    Boot with RAM stick 1 only
    Boot with RAM stick 2 only
    Go buy firewire cable at the store for $32 even though I can get one online for like $2...
    Start in TDM and try running Disk Utility, Disk Warrior, Drive Genius, etc from my iMac
    Hope for the best

    The S.M.A.R.T. status of the drive reads as OK... but I suppose it's still possible that the drive is going bad?
  4. PowerGamerX macrumors 6502a


    Aug 9, 2009
    Thats what it probably is, it's probably just worn out and starting to die. You have to remember, the newest of these machines are 5 years old, and although the build quality of Apple products is good, the 3rd party parts they use aren't always the best.
  5. 666sheep macrumors 68040


    Dec 7, 2009
    Use cellular phones screwdrivers, they fit. Besides: if DW wasn't able to fix your drive, it deserves to be replaced. Even if you'll fix it somehow (I doubt that), it won't be for a long time.
  6. raysfan81 macrumors 6502a


    Oct 6, 2009
    North Carolina
    Do what you want, but it seems stupid not to get a cheap firewire cable off of amazon. It would save you lots of money. And yes the drive S.M.A.R.T status can still be fine if the drive is failing. Like PowerGamer said, you might as well replace the hd as it is probably 5-7 years old now.
  7. mr1970 macrumors member

    Feb 15, 2008
    I replaced the HDD in my PB G4 a year or so ago in order to get more space (nothing to do with faults) and couldn't believe the difference - vastly quicker and quieter than with the original drive. If it is a HDD problem, it's a relatively cheap fix too.

    As others have said, however, you need to take your time when taking the screws out - I think I took out 32 or something ridiculous. You'll need different sized screwdrivers and make sure you're using the right one or you'll strip the heads and they're almost impossible to replace. Oh, and watch when you're taking the F2 key off; it needs to go back on square.
  8. yamabushi macrumors 65816


    Oct 6, 2003
    I agree that it sounds like either bad RAM or a bad HDD.
  9. MacHamster68 macrumors 68040


    Sep 17, 2009
    yes sounds like a bad ram or bad HDD , but i add another culprit the powerbook g4 (the later models ) had been notorious for the ram slot failing sometimes, symptoms can be similar
    and are not always there all the time
    as a mates powerbook g4 sometimes works with the two slots occupied with ram ,other times plays up with kernel panics or sometimes, but not often, it just beeps when booting and doesn't start up , most times suddenly just gets slow like it had the processor speed cut down to 1.5 mhz instead of the 1.5 ghz it normally has and comes back to life as unexpected as it slows down means suddenly one ram slot is not recognised one minute and is recognised the next minute
    there had been a repair extension scheme which, what a surprise ran out in 2008 , so leaving one slot empty i think its the lower slot will solve the problem if yours is affected by the failing ram slot

Share This Page