New to programming - weird error in Xcode

Discussion in 'Mac Programming' started by MoodyM, Apr 27, 2010.

  1. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #1
    I'm learning C++ at at Uni, part time, and I'm using Xcode 3.2.2 at home on my Mac.

    I'm working through some basic example, and my code runs fine when I click buiild & go, but if I then change the code (to do the next example, etc), and click build & go again, I get the following error:

    "Internal Error

    File: /SourceCache/DevToolsBase/DevToolsBase-1648/XcodeFoundation/Logging/XCActivityLogMessage.m
    Line: 120
    Object: <XCBuildLogWarningMessage:0x2005a6300>
    Method: _setSupersection:

    section was already set to <XCBuildLogCommandInvocationSection:0x201031bc0:43:title='Compile /Volumes/USB STICK/Dropbox/UWS/Introduction To Programming/Practice Code/C++ From The Ground Up/2_MyProg/main.cpp'>; expected it to be nil"

    Screenshot:

    http://yfrog.com/jqscreenshot20100427at121p

    I tried completely removing Xcode and reinstalling, didn't help.

    Thanks!
     
  2. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #2
    No idea what the problem is - but I did notice you seem to be opening the project from a USB drive, have you tried copying the project to your hard drive and trying again?

    (I've no idea why that might help, but it's a little better than "have you tried hitting it" or "try turning it off and on again" :) ).
     
  3. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #3
    Yes, same problem running from hard drive.

    Tried on iMac and MacBook, same problem. Tried Xcode 3.2.3, same problem.

    Also I should have added two things:

    1) it's not always the second time I try run it that this happens, sometimes I can amend the code and re-run fine, and I get the error maybe 4th or 5th time I click Build & Go.

    2) if I click Continue at the error message, the code compiles & runs just fine
     
  4. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #4
    I'm not sure what it is. Are any of the files/folders locked?

    I'm not surprised the build works fine afterwards, it looks more like a harmless debug assert than a troublesome error.
     
  5. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #5
    I don't think anything's locked.

    It's now happening every time I Build & Go, but what I've noticed that the error dialog pops up twice. The first time it says:

    Object: <XCBuildLogWarningMessage:0x2005c21a0>

    If I click Continue, I get the same error dialog, but Object has changed to:

    Object: <XCBuildLogWarningMessage:0x200670360>

    Only ONE other person on Google seems to have this error, also from April 2010, and they seem to be on 10.6.3 too, but their files seem to just be in their Documents folder. No solution from them either
     
  6. mkawick macrumors newbie

    Joined:
    Oct 21, 2008
    Location:
    Vancouver, BC
    #6
    I have exactly the same error

    A few things that I've noticed.

    To arrive in this state, I must have a compile error of some sort.
    Now, when I rebuild I get two dialogs each warning me with the text that the previous posted listed.
    Everytime I rebuild, errors or not, I get the same sequence.
    If I eliminate the compile bugs, clean, and rebuild there is no error.
    If I click cancel, XCode crashes and exits.

    This is such a serious error, that I've started using Visual Studio on Windows to build my software. I have lost all productivity in XCode.
     
  7. zophtx macrumors member

    Joined:
    Mar 8, 2010
    Location:
    Inside a Cocoa Book
  8. lloyddean macrumors 6502a

    Joined:
    May 10, 2009
    Location:
    Des Moines, WA
    #8
    I've built many commercial game, educational and music titles consisting of thousands of C++ source files under Xcode with very few problems.

    Your opinion is just that, your opinion - and has no basis in fact.

    Please retrieve your 2¢.
     
  9. lee1210 macrumors 68040

    lee1210

    Joined:
    Jan 10, 2005
    Location:
    Dallas, TX
    #9
    Have you guys reported these errors to apple? Their devs are only human, too. Giving them an error report might just help them fix this.

    -Lee
     
  10. Bill McEnaney macrumors 6502

    Joined:
    Apr 29, 2010
    #10
    I don't know what's wrong. But I do know that you can compile a C++ program at a command prompt.
     
  11. lucaseve macrumors newbie

    Joined:
    Mar 28, 2009
    #11
    Yes they are human beings and, as such, quite lazy.
    There are problems in xCode they never cared to fix/solve.
    I develop software for Mac since 1987 and is disappointing to say that Visual Studio is so much better than xCode.
    I really miss CodeWariorr...
     
  12. lucaseve macrumors newbie

    Joined:
    Mar 28, 2009
    #12
    Workaround

    Looking at the assert description it seems is something related to compilation warning message logging.

    Quickly analyzing the type of warnings I found a workaround that works, at least in my situation.

    Just set the compiler version to GCC 4.0 in project configuration.

    If you must use 4.2 then, perhaps, fiddling with warnings and or compilation configurations may help.

    Bye

    Luca
     
  13. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #13
    Is Visual Studio not developed by human beings as well? ;)
     

Share This Page