New WiFi Issue

Discussion in 'iPod touch' started by Resist, Aug 19, 2008.

  1. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #1
    My Touch all of a sudden will not connect to my wireless network. It shows my network in the settings and even accepted the password (which was my WEP code) but I can't connect to the internet. If I use my neighbors wireless network I can connect just fine.

    This is the first WiFi issue I have ever had with my Touch. How can I fix things?

    So I ended up doing a restore to my Touch and that didn't fix my WiFi issue. Not only that now I lost those extra 5 apps I paid for....WTF?

    Okay so I updated to 2.0 thinking that may solve my problem....not one bit. But at least I got my 5 apps back this way.

    This problem is really pissing me off. I have reset my modem and wireless router. I have entered my WEP code in numerous times. My Touch accepts it and shows a good signal strength but will not allow me access to the internet. WTF!!!!! It used to work fine around a week ago.
     
  2. adbe macrumors 6502a

    Joined:
    Jul 11, 2008
    #2
    If you can connect to your neighbour's wireless network, why are you so convinced the problem lies with the iPod?

    Have you tried rebooting your router? Have you checked the router settings to verify that the Touch isn't being blacklisted (or more typically, is still in the MAC address whitelist)?
     
  3. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #3
    I have reset the router and Touch as well as checked all the info more than once. I have read all the forums about this issue. My Touch can see my server name and shows full signal strength but claims it has no access to the internet. My router is several years old, a WRT54G and I just updated the firmware to v4.21.1but none of this has helped. We have 2 Tivo's, a laptop and an XBox 360 connected to my wireless network, all work fine except my iPod Touch. The max number of DHCP users is set to 20 for the router.

    Some people have said their fix was buying a newer style router. I hate to think I should have to do this when my Touch worked just fine a week ago with this old router. Not sure why all of a sudden it would stop working.
     
  4. adbe macrumors 6502a

    Joined:
    Jul 11, 2008
    #4
    You shouldn't need to buy a new router, or replace the Touch. However, you never stated whether your neighbour's connection is protected. Maybe, if it isn't, you should find a friend with a router set to use WEP (why not WPA BTW?), and see if you can get the Touch to connect to that. Obviously if that test fails, then the Touch is suspect. Otherwise, if both devices work fine with other devices, the problem is most likely to be a config thing.

    What you describe certainly sounds like what I would expect to see when settings are wrong. Depending on the device, incorrect WEP keys may not cause a connection failure, but rather would deliver a connection that is unroutable. Similarly, misconfigured gateway, or DNS IPs will tend to produce problems that match what you describe. When the Touch is connected, check the IP addresses that it is showing for DHCP against those that your router should be delivering.
     
  5. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #5
    It is not protected.
    As I stated before nothing has changed as far as the network settings go, then all of a sudden my Touch (while showing a good signal and showing my network name) won't access that Internet.

    And yet again....I have checked and recheck the code and info and all match perfectly. I have sync'd, rebooted, reset both my Touch, router, cable modem and computer numerous times. As well as changing the WEP code.

    I just tried using WPA, now that my router has that option with the new firmware but while my Touch took the code and seems like it is connected to my network it still won't let me get access to the Internet.

    I also unprotected the router and my Touch is still not allowing access to the Internet. Yet my other devices have no issue going through this wireless router and getting online. This makes me think the iPod Touch is the problem. Why it allows me access to other wireless networks and not the one it has been assigned to since last December, is beyond me.
     
  6. Texas04 macrumors 6502a

    Texas04

    Joined:
    Jul 2, 2005
    Location:
    Texas
    #6
    Static

    My iPod Touch regularly does this... the only fix I have found is to change the settings on the iPod Touch.

    Go into your WiFi settings on the Touch and click the blue arrow next to your WiFi name. Change it from DHCP to static and give it a new IP that another machine is not using. When you exit the settings, it should work. If the iPod doesn't connect to the internet again, repeat these steps with a different IP.
     
  7. Diseal3 macrumors 65816

    Joined:
    Jun 29, 2008
    #7
    and do us a favor and instead of complaining make sure your not broadcasting wireless N only. The ipod/iphone only support up to G.
     
  8. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #8
    Hey thanks for the informative reply. My router is using mixed B and G.

    I have tried this and still it doesn't work.

    It now works! Here is what I ended up doing. I shut off my Linksys wireless modem overnight. The next day I turned it back on and my Touch did not see my named network but it did show a Linksys network. My computer did not even see my named network and could not connect (and it is directly wired to the router). I figured since my Touch was only seeing one wireless network (the Linksys) it was most likely for my modem. I choose it and was able to get Internet access. Then all of a sudden the Touch saw my named network, so I chose that one and it worked too. Then my computer got Internet access.

    Very touchy. Not sure if my router didn't like the Touch or my Touch didn't like my router but today it is working and I didn't have to purchase a new router. My router stays on 24/7 so maybe at times it just needs to be shut down and take a rest.
     

Share This Page