New wireless MightMouse choppy+laggy on 13"MB

Discussion in 'Mac Basics and Help' started by vinyls, Feb 25, 2009.

  1. vinyls macrumors member

    Joined:
    Feb 21, 2009
    Location:
    Northampton
    #1
    Basically i received my MM today in the post and got it set up and running.. thinking about it now i didnt even use the CD to set it up.

    i put the CD in to set it up.. clicked on the wireless logo.. and found the mouse quickly so i just ejected the cd without using it and packed it away...

    anyways so iv been using it for about an hour now and im NOT happy with its responsiveness ATALL!! its laggy!! im used to a perfect mouse just moving across the screen seamlessly!! but this one seems to look fine, but every, lets say 10cm of movement it will slow down a bit and then speed up?!?!

    this is seriously unacceptable froma £50 mouse when iv been using a £20 laser mouse before and it was perfect!!

    now have i set it up wrong? the batteries are new so it cant be them and the charge level is at the top.. is it my surface? (tried it on a mouse mat so cant be)

    i would like to add that i notice it most while moving the mouse slowly (ie trying to hit a small icon like the cross button on the top left) which makes it VERY hard to do general things on this laptop..

    PLEASEEE any1.. i would appreciate it sooo much THANKS
     
  2. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #2
    I didn't need to put any CD in to get mine working, i just take it near my MBP, pair the devices and voila away we go!

    Its slow I agree (i set the speed to max in the preferences panel under mice, and it compensates this just fine), but not laggy at all, that sounds like an old/broken bluetooth 1.0 card to me. (now we have 2.1). Certainly not a battery issue, but moving your mouse nearer the bluetooth receiver on your computer should help.
     
  3. vinyls thread starter macrumors member

    Joined:
    Feb 21, 2009
    Location:
    Northampton
    #3
    well i put the tracking speed up to max in the first place becz it was slow, tbh its just when i move my mouse slowly that its really effecting me, if im wizzing from one side of the screen to the other.. no problem atall but when im editing text (like here) for example and i just go to one part of the sentence at a slow/average speed.. it almost feels like the mouse puts the breaks on for a second or to then kicks back into gear..

    although the mouse is moving perfectly smooth.. its an odd one this is.
     
  4. vinyls thread starter macrumors member

    Joined:
    Feb 21, 2009
    Location:
    Northampton
    #4
    im starting to think that the mouse is just generally slow, and i cant really feel it while wizzing around but when i slow down.. it really does SLOW down..
     

Share This Page