Newbie - Iphone 3Gs - unlockable and jailbreakable?

Discussion in 'Jailbreaks and iOS Hacks' started by Tampaite, Jan 28, 2011.

  1. Tampaite macrumors newbie

    Joined:
    Jan 28, 2011
    #1
    Newbie here and have been browsing thro' several threads for couple of days...

    Need clarification.
    Did buy an AT&T Iphone 3Gs on ebay and now trying to unlock it so I can use it on T-Mobile network.

    I used the f0recast tool to determine if it can be unlocked or not and am disappointed with the results.

    Attached the Image.

    Beware: the Forecast.exe has a malware attached to it - called Dropper.Generic2

    Here are the details

    Baseband : 05.15.04
    Bootloader: 6.4
    Model : MC132
    Firmware : 4.2.1

    Jailbreakable? Only with SHSH Blobs
    Unlockable? NO
    Tethered? Depends on Jailbreak.

    I would appreciate any pointers on how to unlock/jailbreak the phone.
     

    Attached Files:

  2. CZK macrumors 6502a

    Joined:
    Oct 25, 2010
  3. Tampaite thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #3
    Thanks..have been reading that but am getting conflicting information.

    On one hand, am told I need to "install iOS 4.1 to get an untethered jailbreak" and/or "update the baseband to 06.15.00"

    This link seems to walk me thro' step by step but just need confirmation from anyone this board that it indeed worked..am a bit paranoid but also would like to use iphone on T-mobile network :D
     
  4. CZK macrumors 6502a

    Joined:
    Oct 25, 2010
    #4
    4.2.1 is untethered on iphone 3gs

    install 06.15.00 baseband to unlock

    follow the guide that is written on dev team blog..........
     
  5. labman, Jan 28, 2011
    Last edited: Jan 28, 2011

    labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #5
    before you do this understand

    WARNING:

    YOU DO THIS AT YOUR OWN RISK! PLEASE UNDERSTAND THE CONSEQUENCES OF UPDATING TO 06.15.

    1. There is no way to come back down from 06.15, and there’s no hiding the baseband version from Apple. You’ll be voiding your warranty in a very obvious way.
    2. If some future baseband comes out with a critical fix, you won’t be able to update to it if it remains down in the 05.xx sequence (then again, you wouldn’t update to it if you wanted to keep your unlock anyway).
    3. Starting with FW 4.2.1 if you have 06.15 on your iPhone you won’t ever be able to restore to stock firmware (it will fail). You’ll need to only restore to custom IPSWs (then again, if you’re unlocker you should already be doing that).
    4. many many complaints about loosing GPS fetures.

    might also check out this thread

    http://forums.macrumors.com/showthread.php?t=1087104
     
  6. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #6
  7. CZK macrumors 6502a

    Joined:
    Oct 25, 2010
    #7
    Yeah forgot to mention tethered for new bootrom 3gs
     
  8. Tampaite thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #8
    Looks like I won't be able to have an untethered version.

    my bootrom version is 359.3.2. see the attachment below..
     

    Attached Files:

  9. Tampaite, Jan 29, 2011
    Last edited: Jan 29, 2011

    Tampaite thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #9
    Need expert opinion....

    Do I wait until iphone-devteam team works on an untethered option or am I better off buying a iphone 3Gs phone with an older bootrom and lower baseband and firmware?

    Edit: my concern is once I got to a tethered JB, can I update to untethered JB in future?
     
  10. Tampaite thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #10
    I would really have an untethered jailbreak rather than tethered and will wait until 4.2.1 untethered jailbreak will be released.

    In the meantime, did some more reading/digging and need expert opinion..

    I found this quote online -

    " If you have SHSH files, with Cydia Or TinyUmbrella, you can put your device into DFU mode and downgrade to iOS 4.1. If you downgrade you can then jailbreak untethered with limera1n Or Greenpois0n."

    Is this do-able for 3GS with firmware 4.2.1 and baseband 05.15.04 with new bootrom.

    Appreciate your help!
     
  11. Ban187 macrumors newbie

    Joined:
    Feb 25, 2011
    #11
    Hey guys, i've got the same problem, i live in germany and my iPhone is from Poland with this Orange SimLock.

    The thing is, my English isnt the best, and there are parts of the page that i cant understand from the def-team.page...


    the other thing is, i had it jailbroken, but my iPhone battery was empty and when i tried to reboot it with redsn0w it didnt work, so i tried to re-jailbreak it, and now its stocking when he starts jailbreaking. then i did a recovery, and now its telling me the same thing as written above in the quote.

    could some one tell me what to do? i dont care if its un- or just tethered, i just want to make it work with a jailbreak and have no simlock on it, to be able to use my german "E-Plus" card. and there is no warranty on my iPhone, that means no dealing with apple. please help me out. best wishes from germany
     

Share This Page