Newbie:- time machine?

Discussion in 'iMac' started by rafcorporal, May 20, 2018.

  1. rafcorporal macrumors newbie

    rafcorporal

    Joined:
    Feb 12, 2018
    Location:
    Derby England.
    #1
    Hello everyone, I am new on this site and reasonably new to Apple. I have a 2017 21inch iMac running High Sierra 10.13.4. I also run SuperDuper as my back up on an external 1TB HD. My problem is this, sorry but I do not like TimeMachine (personal preference), and I would dearly love to disable TimeMachine altogether. I have been in system preferences> TimeMachine but I cannot find the slider type switch that is used to switch it on or off - (the picture in instructions show this control), slide to the right for on and to the left for off! Nowhere to be seen and the result is continuous "nagging screens" prompting me to use TimeMachine! I am getting brassed off with them as they appear at least twice per day and sometimes more than that. Please give me detailed instructions as to how to disable the pest TimeMachine
     
  2. afir93 macrumors 6502a

    Joined:
    Jan 5, 2018
    #2
    The slider-type on-off control was replaced sometime in the last macOS updates with a checkbox that is (for me) in the same place as the slider was before... is there no checkbox for "automatic backups" or something that you can just turn off?
     
  3. rafcorporal thread starter macrumors newbie

    rafcorporal

    Joined:
    Feb 12, 2018
    Location:
    Derby England.
    #3
    Hi afir93, Thank you for your reply. Yes there is a check box for 'Backup Automatically' and it is unchecked (Does not have a tick in it). This I assume means it will not backup on TimeMachine, but I still get the nag screens so it is in my mind not disabled. I think TimeMachine cannot be deleted as it is built into the iOS? Although this bugs me I doubt if I will return to Windows as Apple is so superior!

    Very best regards from Keith in Derby England.

    So you failed to prepare; now prepare to fail.
     
  4. afir93 macrumors 6502a

    Joined:
    Jan 5, 2018
    #4
    Yes that's the checkbox I meant. That's definitely weird then; I don't think this should be standard behavior. What do these nagging screens look like and when do they show up (i.e. only when you plug in an external drive, or at other instances aswell)? What I could think of is that maybe the time machine preferences-file in the library or user library is corrupted? Maybe try deleting them (ideally with backing them up first) so that they are recreated and see if the issue keeps happening?

    Best regards.

    Edit: a Google search yields this thread over on stackexchange that sounds quite like your issue. The thread is a bit older already but maybe one of the suggested solutions from over there might help?
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    From my archives (not sure if these still work):

    To turn Time Machine on or off, you can run these commands:

    sudo tmutil enable

    sudo tmutil disable



    TO PREVENT TM FROM ASKING ABOUT NEW DISKS:

    defaults write com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool TRUE

    Then log out and back in again for the changes to take effect.
     
  6. rafcorporal thread starter macrumors newbie

    rafcorporal

    Joined:
    Feb 12, 2018
    Location:
    Derby England.
    #6
    Hi Fisherrman, where exactly do I type in sudo tmutil disable , (I am not very computer literate)?
    Best regards from Keith in Derby.
     
  7. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    1. Copy the command
    2. Open Terminal (in utilities folder)
    3. Paste in command and hit return
    4. Terminal will request password
    5. Type in password (you WILL NOT see characters as you type it in)
    6. Hit return
    7. Done
     
  8. rafcorporal thread starter macrumors newbie

    rafcorporal

    Joined:
    Feb 12, 2018
    Location:
    Derby England.
    #8
    Good morning Fishrrman, I can hear your sigh of complete frustration from here! Sorry but I did warn you I am not very computer literate; items 1, 2,3,4,and5 are in a strange language to me; items 6 and 7 I am OK with. Apart from (in utilities folder) where is that item?, 'Copy and paste the command' is beyond me. I am thick and stupid on a computer, I am almost 84 years old and claim a "Senior Moment". Thank you very much for your help, I really do appreciate your time. I think I will just tolerate the Time Machine having it's moments; it must know what sort of person it is dealing with.

    Very best regards from Keith in Derby England.
     
  9. J.Gallardo macrumors regular

    J.Gallardo

    Joined:
    Apr 4, 2017
    Location:
    Spain
    #9
    Well... perhaps we need to explain somethings very clearly:
    -There is not a slider in Time Machine preferences panel anymore (I think it was a slider before). Search for a white square under Time Machine logo (in its preferences panel). Untick it. Maybe you have to "unlock" first to make changes (click on the padlock logo, down-left, and follow instructions).

    I think it could be easier for you, in first instance, trying to disable Time Machine in the "traditional" way.

    If this doesn't work, Fishrrman gives you a very good clue, and -really!- it's not as difficult as it seems. (Fishrrman posts very good advices, but he is very laconic; always ;)).

    I'll follow this thing, & would try to translate Fishrrman solution in a way a respectable senior deserves, but I think you have to investigate Preferences Panel again.
     
  10. rafcorporal thread starter macrumors newbie

    rafcorporal

    Joined:
    Feb 12, 2018
    Location:
    Derby England.
    #10
    Hi J.Gallardo, the white square under the Time Machine logo is not ticked and I cannot find the 'padlock'. I am aware of it and have seen it in the past but it is not on Time Machine, I have opened Time Machine from every available start point in an effort to trace the padlock but have not been successful. As a result of all this I feel I will just have to tolerate Time Machine and it's persistance. Thanks to Fishrrman and yourself, i really do appreciate your time.

    Very best regards from Keith in Derby England.
     
  11. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #11
    Isn't it true that if you don't have a hard drive designated for Time Machine backups then Time Machine is "OFF"?
     
  12. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #12
    You still get the nag - "Do you want to use this drive for time machine?" I got it yesterday plugging in a new drive into a MBP with TimeMachine turned off. I assume it only pops up once but haven't tested this.

    On MBPs with Time Machine ON, they do not get the nag when plugging in new drives.
     
  13. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #13
    Not sure if the Terminal command in this article still works for that.
     
  14. J.Gallardo macrumors regular

    J.Gallardo

    Joined:
    Apr 4, 2017
    Location:
    Spain
    #14
    ...Not exactly...
    I didn't like the idea of hourly backups, so I installed "TimeMachineEditor" app (free) to easily manage TimeMachine behavior.
    My "TimeMachine" preferences panel shows it's off, but my system makes daily backups at a specified time. I suppose that "off/on" is related to "Use TimeMachine in standard mode & make hourly backups".
    Also, even in "off" mode, you can order to make a backup "now" from the TimeMachine icon in upper menu-bar.
     
  15. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #15
    I made the mistake of formatting my new 3tb drive and copying tons of data to it only to find time machine won’t work with it. So formatted and started again. I let time machine encrypt the drive then copied all my data again. $£%# - should have just formatted it encrypted. Now it’s gunna take weeks to encrypt. Lol. And wow does it back up slower encrypted. :(
     
  16. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #16
    You can't use TimeMachineEditor without having a hard drive designated for Time Machine backups.

    I think the OP is NOT using TM but is annoyed by prompts when mounting external drives. There isn't a "Don't Ask Me Again" checkbox in the prompts...which there ought to be since there are multiple ways to back up a Mac.

    The thing is...I thought once you mount a drive, get the TM nag, and tell it NO that you don't get the nag again, as BighMcGuire says, for that drive unless you change the drive (format or partition) in some manner.
     
  17. J.Gallardo macrumors regular

    J.Gallardo

    Joined:
    Apr 4, 2017
    Location:
    Spain
    #17
    Yes, you're right:
    I must have forgotten I accepted my TimeCapsule as TiMa backup disk. I think I put TimeMachine in "off", so I could trigger by myself a backup from icon in upper menu-bar. After that I discovered this nice app (TimeMachineEditor) to better manage TiMa...
    Yes, you point to the problem here:
    It seems OP's mac can't remember that user has refused to use a specific disk as TiMa target. So, as you say, if mac keeps asking, it should be because it keeps thinking attached disk is a new one. Or TimeMachine app (aren´t preference panes apps?) isn't working properly and can't remember disks in general. Could it be a corrupted plist file...?
    Anyhow, more details about OP's system could help to figure why this happens.
    If not, Fishrrman's solution should work, but TimeMachine would turn totally disabled, and it's not a perfect fix (OP doesn't want to use TM, though).
     

Share This Page