Newbie to Jailbreak Unlocking...PLEASE ADVISE!!!

Discussion in 'Jailbreaks and iOS Hacks' started by wireless-toyz09, Oct 2, 2009.

  1. wireless-toyz09 macrumors member

    Joined:
    Aug 2, 2009
    #1
    Hello everyone, i have an At&T Iphone 3g 8gb version 2.1 and modem firmware 02.11.07 with at&t 2.6 and i have had my iphone unlocked with the ismart sim card for almost a year now with no problems. My dilemma is i want to upgrade to 3.1/3.01 firmware and of course there is no turbo sim/ ismart sim/ rebel sim available as yet and i am tired of waiting because i want the new features and the ability to install the updated apps. It is a MUST that i am able to unlock before i upgrade as i use it mostly in the Caribbean. I have NEVER jailbroken my iphone because the ismart sim was so much easier and i am not into all the hacks. I just want the iphone carrier unlocked is all. I wanted to know if i jailbreak unlock with ultrasnow or pwned or one of those programs, can i delete cydia after i unlock it and also i wanted to know if after i jailbreak, will the app store still be usable?? (As I use it daily) Also, can someone also recommend the EASIEST unlock right now for 3.1/3.01 and a link to a guide?? :confused::(

    All suggestions would be appreciated.
    Thanks:eek:
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Did you even try searching? You could have found all the answers in a shorter amount of time than it took to type that long post. Go here, and download Pwnage Tool. Then make a custom 3.1 IPSW and restore the phone to that using iTunes, and then download ultrasn0w. Done.

    Yes the app store will still work normally. If you don't want cydia, you can hide it using BossPrefs.

    Here is a great guide with pictures.
     
  3. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    Man, with a handle like wirelsss-toyz I figured you'd be a wiz at this stuff. ;)
     
  4. wireless-toyz09 thread starter macrumors member

    Joined:
    Aug 2, 2009
    #4
    can i Upgrade/ jailbreak/ unlock from 2.1 straight to 3.1???:confused:
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    I wouldn't have told you to do it, if it wasn't 2.1 to 3.1 compatible.
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    @jmann

    Must be that wigglin' apple that scares 'em.
     
  7. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #7
    Go to official 3.0 first, THEN make a custom 3.1 firmware that doesn't update the baseband with PwnageTool and DFU restore to it.

    If you don't, you'll end up with a non-working baseband like I did.
     

Share This Page