newbie- unlock iphone 4 to tmobile possible?

Discussion in 'Jailbreaks and iOS Hacks' started by unknown00, Apr 12, 2012.

  1. unknown00 macrumors member

    Joined:
    Nov 17, 2009
    #1
    so i'm thinking of getting an iphone 4 (not 4s) since my android broke today. i've been hearing rumors that it is not possible to unlock an at&t to tmobile with ios 5.* or something? i plan to get a used iphone 4 and i won't know what version of ios it's running prior to buying. i just want to clarify rumors right now, please assist
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Its true that if its on stock 5.0 or higher it cannot be unlocked with ultrasnow or a gevey turbo sim.
    But latelly AT&T has been officially unlocking iphones that are out of contract so you can have the seller try to officially unlock it by calling tech support or you can attempt it once you get it.
     
  3. unknown00 thread starter macrumors member

    Joined:
    Nov 17, 2009
    #3
    is there no way to flash to ios 4.* then unlock?

    i plan to buy from a website so can't ask user to unlock for me lol i don't think attempting to do it myself will work either
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    No, once the baseband has been updated it cannot be downgraded even if there are shsh blobs saved to downgrade the firmware version.
    Baseband is what determines the unlock.
    You'd be surprised, many users that dont even have an AT&T account called and had their iphones unlocked. You just gotta get lucky and speak to a helpfull rep.
     
  5. unknown00 thread starter macrumors member

    Joined:
    Nov 17, 2009
    #5
    interesting, my next question - lets say i buy an iphone 4 with ios 4.* and i get it unlocked myself, can i upgrade to 5.* and it remain unlock? or am i stuck with 4.* forever?
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    You gotta make sure the baseband can be unlocked either with ultrasnow or a gevey. Cause someone can sell you an iphone 4 that's on 4.3.3 for example but has been updated to 5.0.1 and then downgraded back down so then the baseband got updated and even if its on 4.3.3 now it cannot be unocked.
    Gevey is a little tricky and needs a few steps every time you turn on or restart your phone so read up on it.
    There's many different things you need to research and get familiar with iphone unlocking. Like unlocks such as ultrasnow or gevey are not forever, if you ever update to stock firmware you will lose the unlock for good.
     
  7. unknown00 thread starter macrumors member

    Joined:
    Nov 17, 2009
    #7
    so what exactly should i look for to make sure it is unlockable?
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Unlockable basebands for iphone 4.
    01.59.00 iPhone 4 Ultrasnow and Gevey
    02.10.04 iPhone 4 Gevey
    03.10.01 iPhone 4 Gevey
    04.10.01 iPhone 4 Gevey
    If it has any other baseband higher than 04.11.01 then it cannot be unlocked.
     

Share This Page