Newbie with printing network problem

Discussion in 'Mac Basics and Help' started by swilbaby, Dec 3, 2010.

  1. swilbaby macrumors newbie

    Joined:
    Dec 3, 2010
    #1
    Hello Mac world, I'm new to Macs and forums, so be gentle. I have been given an iMac g3 with osx 10.4.11 installed and airport card. My son will have this as his first computer.

    It is up and running and surfing the net using the airport connected to our home network. I have searched the forums and tried all the results I could find but am still unable to print from the iMac to my network printer.

    iMac G3 10.4.11 osx slot loaded, airport wireless. Officejet all in one 6310 usb to pc running Vista. I have tried all the usual SAMBA and LPD methods listed going for generic printer, but get error 256 using printer utility, and NT_status_no_memory when using samba with all the settings, when trying LPD the printer service just stops.
    I use LPD://user:password@workgroup/server/sharename and same for smb.
    I have set up a seperate account for the mac on the vista pc with password and started lpd service I've also edited the registry for lmcompatibility, printer sharing is enabled and both machines have the same workgroup name (WORKGROUP).

    I am now at a loss and cannot find any other methods to try, if anyone can stop me from losing my mind, I'd be gratefull. Thanks.
     
  2. ReelAction macrumors member

    Joined:
    Nov 30, 2010
    Location:
    NorCal
    #2
    I had a similar problem when trying to get a Canon 560 connected via wi-fi.

    This is what finally got it working;
    select the scanner icon in the top title bar and activate the 6310 scanner
    then go to system preferences, print&fax, and add a printer, wait 5-10 seconds for the 6310 to show in the list, then select it (Note: do not select the Bonjour Scanner)
    Maybe this will help get you up and running.
     
  3. swilbaby thread starter macrumors newbie

    Joined:
    Dec 3, 2010
    #3
    Thanks for the reply, I'm confused where is the scanner icon? Is it on the Mac or the PC?
    Thanks,
    Stu
     

Share This Page