Newer Macbook Pro, Charging Issues, Trash Issues, Hard Drive Issues... Details Within

Discussion in 'MacBook Pro' started by frajeff91, Apr 2, 2010.

  1. frajeff91 macrumors newbie

    Joined:
    Apr 2, 2010
    #1
    I'm having so many issues with this thing that I'm considering just taking it to the apple store to have them fix it.
    Though I can't remember how long the warranty is.
    Anyway, I'm on a Macbook Pro, ordered August 2009.
    The first issue, and least important issue, is that I'm having issues with my trash bin. If I click and drag an item to the trash bin, nothing happens. If I "right click" a file and hit delete, it tells me that it's permanent am I sure yadda yadda, and then just permanently deletes the file, bypassing the recycle bin altogether. Hasn't been an issue until today when I accidentally deleted the wrong file and lost about 12 hours of work.
    My second issue, slightly more important, but still not the most important, is that my charger seems to be malfunctioning. Whenever I plug it in, it glows a dull green, and the top, where it usually says charging or charged usually says "Not Charging", and then at random times throughout the day, it gets fed random bursts of power until it's charged. Sometimes the battery gets so low that the computer damn near dies. At any rate, it's not a huge issue because most of the time when I fiddle with it, a better connection is made, and it starts charging.
    The third issue, and currently most important, is my external hard drive. It's running slow as hell. It's a ... I couldn't tell you the make, but it's a sata drive plugged into a sata to ide adapter, then in in ide enclosure. The read speed is normal, fast as hell, but the write speed, by my math (which is right) is 0.02 megs per second. It took over an hour to write 78 megs to the drive. Now there's a lot of specifics going on with this issue. For example, after about twenty or so minutes of copying, the drive or the computer seem to give up, telling me that it can't find the files I'm copying, even though they're in the same exact place. Well that's easy to get around, I just start the copy again from where it quit, and magically it's now able to find the files. Anyway, here's what happens. The copying dialogue comes up, and the bar gets filled a little tiny bit, and then just sits there, not moving. The file part will say something like "XX.X mb out of XX.X mb". Just like normal. Except that neither the bar or the numbers are movie. Well they'll sit like that for about five minutes, and then for about five seconds, things will start moving normally. But after that five seconds, things just lock up again. Here's the odd part. During that five minute time period, my entire finder locks up, so I can't browse files. Plus, if I'm working in photoshop, or a file converter, or any program, and I go to file->open, the program locks up. That is, until that five second period where the copy goes smoothly. Any programs will instantly start working again, the file->open stuff works fine as long as I don't close it and reopen it, and finder starts working correctly unless I try to move or open anything, in which case it locks up again until that five second period.

    BIZARRE.

    Anyway, I downloaded xbench to run a benchmark on the external and here's what came up ..
    Sequential 1.77
    Uncached Write 35.98 22.09 MB/sec [4K blocks]
    Uncached Write 1.43 0.81 MB/sec [256K blocks]
    Uncached Read 1.76 0.51 MB/sec [4K blocks]
    Uncached Read 1.04 0.52 MB/sec [256K blocks]
    Random 44.81
    Uncached Write 20.15 2.13 MB/sec [4K blocks]
    Uncached Write 56.79 18.18 MB/sec [256K blocks]
    Uncached Read 85.92 0.61 MB/sec [4K blocks]
    Uncached Read 96.27 17.86 MB/sec [256K blocks]
    As you can see, the numbers are really low. But my math and their math didn't agree with one another. They weren't the ones who sat for an hour waiting for the transfer to finish, the number is 0.02mb/s.

    THESE ARE A LOT OF ISSUES.... and could be all software related.... but I'm new to macs, so hell if I know.


    Anyone feel like shedding some light on these situations? <3
     
  2. ThirteenXIII macrumors 6502a

    Joined:
    Mar 8, 2008
    #2
    Trash issue seems like a permissions problem.
    one way to test is to create a new user account, make some disposable files (ie, download some images, create a few text files) drag them to the trash see if it makes a difference.

    Charger - could be the DC board of the actual computer and not the charger itself.
    or even perhaps the battery.
    best is to get them all checked out.


    Your external drive.... Honestly, I say take it out of that IDE enclosure, go find a nice enclosure (they make USB2 and USB2/FireWire enclosures dirt cheap find one you like on Newegg.com), there is really no point in having Sata Drive to a sata->ide convert to IDE enclosure... probably causing your problems right there.
    simplify that set up.


    back up your data and try a clean install if permissions issues are persistent with access to your files on any of your drives and your trash permissions are broke.
     
  3. frajeff91 thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #3
    The IDE enclosure can't be that big a deal, I know other people who do it and don't lose much speed, if at all. Simplifying it just isn't an option right now, I've got exactly $0 to throw around for a new enclosure, no matter how dirt cheap they are, it's not an option. Plus, even IDE enclosures are supposed to run at 100mb/s and this IS a usb2.0 enclosure, it's not like it's old, it's brand new. There's no way that it's causing a 99.8 mb/s drop in speed, that's a ridiculous assumption... I mean, isn't it? Especially considering that the read speed is as fast as it should be? (copied a few music files in the blink of an eye)


    Also I should note that backing anything up is impossible without this drive working :p

    EDIT: Okay, sometimes when the external decides it can't see files anymore, it locks up finder, which then quits, and when I try to relaunch it, a box pops up that says "The application Finder can't be opened. -10810"
     
  4. kny3twalker macrumors 65816

    kny3twalker

    Joined:
    Oct 25, 2009
    #4
    Honestly sounds like the drive is failing. Can you test it in a desktop? If it's ok in a desktop, then your enclosure and adapter are the issue. Go spend the $20-$30 and get one that works if it will solve your problem. As far as the charger, take it to apple.
     
  5. frajeff91 thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #5
    Like I said, money is an issue, I can't spend it because I don't have it.
    the mac OS reads the IDE to SATA adapter as running at 433 mb/s, so I'm fairly certain that it's not the issue.
     
  6. kny3twalker macrumors 65816

    kny3twalker

    Joined:
    Oct 25, 2009
    #6
    First I said I think it's the drive not the enclosure. Then I suggested how to test my hypothesis. Then it can be concluded if it's the drive or enclosure. And if it is the enclosure, you have two options: suffer through the headaches or spend the money by whatever means whether it means skipping meals or picking up pennies.
     
  7. frajeff91 thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #7
    I could technically test it in a desktop, but I'd have to go borrow one from someone and make sure that they've got a spare 3.5" SATA bay... It came from a desktop originally, it was used inside my old PC for a year or two. Then it sat around in a drawer for four months... It wasn't moved much after that, it literally just sat there. I suppose it is possible that that could've wrecked part of the drive.

    I've got some updates though. I'm using this drive to play mp3s and avis on my surround sound system (the receiver plays both filetypes) and I'm pretty sure it needs to be in FAT32 format for it to recognize it (because I know for a fact it doesnt read HFS+ cause I tested it earlier). The problem is that inside OSX, formatting the drive as a FAT32 drive bricks the HDD and my operating system until I either unplug the HDD or cut the power to it. Then I have to reformat it as an HFS+ before opening finder, or it bricks me again. So I booted into windows and attempted to format it there. I can format it in four tiny partitions of FAT32, but I lose most of the hard drive, because it's a 250 gig hard drive, so that's a massive waste, but it WORKS. I tried formatting as an NTFS, and no matter what I do, how I try, how small I make the partition, where I make the partition, no matter what, the NTFS format always fails, always. Yet the FAT32 works.
     
  8. kny3twalker macrumors 65816

    kny3twalker

    Joined:
    Oct 25, 2009
    #8
    Try running some tests on the drive. I am betting it is going bad. I had three fail on me in 09, and this sounds like similar behavior.
     
  9. bluskale macrumors regular

    Joined:
    Mar 29, 2010
    #9
    your laptop comes with a 1 yr warranty by default, and a 3 yr total if you add applecare at any point in the first year (oddly, this is often considered a good buy, even though most warranties are not)

    take your laptop into an applestore and have them take a look at it... the charging issue might require some replacement parts, so it could be a few days before you get it back. You could try to figure out the trash thing on your own, but they should be able to help you with this too. afaik this should all be at no charge under warranty. Make sure you back up your data before you take it in, just in case (burn a few dvds, if nothing else)
     
  10. frajeff91 thread starter macrumors newbie

    Joined:
    Apr 2, 2010
    #10
    Yeah, the problem is that I literally can't back up any of my data. I don't have empty dvds just sitting around and I can't go get any, so if I take it in and I lose my stuff, then I'm SOL I guess. To the poster before the one I'm quoting, would the drive really write FAT32 just fine and hiss in the presence of NTFS if it was going bad? Technology is so bizarre :p How's a guy supposed to know when he's doing something stupid or if something is broken?
     
  11. bluskale macrumors regular

    Joined:
    Mar 29, 2010
    #11
    well... depending on how much data you have to backup, you could try putting it online :p

    also, I was reading something the other day about how the airport extreme writes very slowly to usb drives with certain chipsets.... but only when the drive is hfs+ journaled. I don't know if switching to hfs+ (nonjournaled) would be of any help here. While you're at it, set up the partitions again in disk utility, just so everything is fresh there too.

    If my external harddrive was doing that, I would assume it was failing too.

    addendum: as a sidenote, in a fully functioning drive, FAT32 will perform slower than HFS+, at least the last time I tried it several years back.
     
  12. kny3twalker macrumors 65816

    kny3twalker

    Joined:
    Oct 25, 2009
    #12
    If you are in the Dallas area, I will give you a couple DVDs. And I still believe your external HDD is failing. It most likely has warranty though and can be replaced. Since it sounds like you have more time than money, back your data up to email. I think gmail can take 20 MB files and will hold a few GBs per account.
     
  13. Pax macrumors 6502a

    Joined:
    Dec 12, 2003
    #13
    Re your charger I'd say

    - it's more likely to be the Magsafe charger than the Mac, the chargers have a reputation for being a bit flaky. You could take it to an Apple seller and just try a different charger, see if that helps. No need to worry about backing up unless they diagnose a faulty Mac.

    - If you look in System Profiler under Power it tells you lots of useful stuff about the power circuit. Particularly down at the bottom of the page it says "charger connected Yes/No" and "charging Yes/No". If you post that whole Power page on here at a time when the charger is connected, but the battery is not charging, maybe we can spot something helpful.

    - have you tried resetting the SMC? It involves a complicated 3-finger salute which depends on model. http://support.apple.com/kb/HT3964. SMC controls some aspects of charging, not sure how much.

    Re your trash

    As a previous poster suggested, set up a new user account and see if it behaves as you would like. If that behaves properly, the problem is with permissions on your files or your trashcan.

    For the file right click & Get Info, at the bottom of this window it will give you permissions status.

    For the trashcan go to a Finder window, click on your home folder, then press shift-cmd-G (Goto a folder). A text box should appear, enter .Trash and hit return. Don't forget the leading dot. This should make a grey Trash folder appear in your home folder. (the trash folder is normally hidden, this makes it visible in the Finder). Right click on this and Get Info to get its permissions. Both should be your user name Read & Write.
     

Share This Page