NewerTech Voyager Q failures

Discussion in 'Mac Pro' started by wonderspark, Nov 22, 2013.

  1. wonderspark macrumors 68030

    wonderspark

    Joined:
    Feb 4, 2010
    Location:
    Oregon
    #1
    Back in 2011, I bought a Voyager Q dock by NewerTech from OWC.

    The people at OWC are great, and they lived up to their end of the deal by replacing the first two failed Voyager Q docks. Yes, my third dock has failed.

    First one - May 2011, failed March 2012
    RMA replaced in March 2012, failed a month later in April 2012.
    RMA replaced in April 2012, failed today in November 2013.

    So, it's cool that OWC kept the game going beyond the one year warranty, but those docks are junk. I baby my gear, and I was more than gentle when sliding drives in and out of the dock, simply because I know there is a flaw in the design that allows the connection to break inside somewhere.

    Now that this POS is dead, and I have no hope for replacement or refund, I am going to take it apart and try to find/fix the broken connection. It still powers drives, but never makes a data connection any longer, so it's got to be a loose connection.

    Anyone else have a Voyager Q that lasted longer than 19 months?
     
  2. Macshroomer macrumors 65816

    Macshroomer

    Joined:
    Dec 6, 2009
    #2
    I hate to be *that* guy...but yeah, no issues for nearly 18 months now. I am super careful putting drives in and out.
     
  3. wonderspark thread starter macrumors 68030

    wonderspark

    Joined:
    Feb 4, 2010
    Location:
    Oregon
    #3
    Haha, hey, good for you, mang! I was *super* careful with inserting drives, too... especially after the first one (and then second one) failed. In fact, I mostly just left one drive in the slot the whole time, since it always happens just after inserting a new drive.

    May your luck continue, but it sounds like you have a month or two before you outlast my last one! :p
     
  4. metrocon macrumors member

    Joined:
    Jan 6, 2004
    #4
    I bought one from B&H in April 2012, so I'm right at the 19 month mark right now. Have not had any problems so far, and haven't been super careful inserting or removing drives. I'll probably be more careful going forward though...
     
  5. pertusis1 macrumors 6502

    Joined:
    Jul 25, 2010
    Location:
    Texas
    #5
    Yeah - I've had mine for well over a year (probably 2) without any problems. Granted, I do not use it all that heavily, but it's a wonderful tool for all of my leftover drives from old computers. Sorry you've had trouble. A buddy of mine has had one for several years as well and loves it.
     

Share This Page