Newest MacBook Air topping out at 54mbps wifi connection to my 802.11AC router...

Discussion in 'MacBook Air' started by spaceballl, Oct 13, 2013.

  1. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #1
    Has anyone else had issues with the newest MBA wifi? It's my wife's computer. I have all of the OS X updated fully updated. I'm using a Netgear R7000 802.11ac router, and I'm having this issue on my wife's macbook air. I have a rMBP (non-AC), and it can connect on both the 2.4ghz and 5ghz bands without any issue at all at much higher speeds. My transmit rate right now on my MacBook Pro is 217mbps. When I got to the MBA right next to it, on both the 2.4ghz and the 5ghz band, the MBA is capped at 54mbps. Additionally, when I option+click on my pro, it shows me the "MCS Index" underneath the transmit rate. On the Air, the MCS Index is not shown.

    Does my wife have a defective wifi card in her mac? Is something else going on? Thanks!
     
  2. 3lite macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #2
    Seems to me the wifi upgrades are minimal at best...
     
  3. spaceballl thread starter macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #3
    It's not about upgrades. It's about it not being able to even connect at 802.11n rates, let alone 802.11ac. And being pegged at 54mbps, despite how far i walk away seems like an issue.
     
  4. MacMojo1 macrumors member

    Joined:
    Mar 22, 2006
    #4
    Airport Utility says my new Air connecting at 526mbps to the AirPort Extreme. Not sure if that helps.
     
  5. spaceballl thread starter macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #5
    No I have other machines that can connect at high rates, including my macbook air and my macbook pro. Something is wrong with her machine, it seems. We'll take it in to get checked...
     
  6. calvol macrumors 6502a

    Joined:
    Feb 3, 2011
    #6
    Known issue... see the 115+ page thread on the Apple support forum...
     
  7. everking macrumors newbie

    Joined:
    Feb 11, 2014
    #7
    Having the exact same issue: stuck at 54mbps on MBP Retina

    I have exactly the same issue as your MBA. When I switch to 2.4 GHz network, I'm getting 217Mbit/s, but when I switch to the 5 GHz network (option-click says I'm on the 802.11ac mode), I'm stuck at 54 Mbit/s Link Speed (according to Network Utility).

    From your post, it sounded like I may have a bad wifi card. Is that the case for your MBA?

    Unfortunately, I don't have any other 802.11ac device or notebook to test (or another 802.11ac router to test against, so I'm relying on folks like you to help me out. :)
     

Share This Page