Newly installed W7 taking up too much space.

Discussion in 'Windows, Linux & Others on the Mac' started by skadd, Nov 12, 2010.

  1. skadd macrumors regular

    Joined:
    Mar 5, 2010
    #1
    So I just installed windows 7 x64 (bootcamp) on my iMac 27" mid 2010.

    It seems to be taking up 11 GB more than there really is on the partition.

    Partition size: 33 GB
    Used space: 22 GB (in reality 11 GB)
    Free space: 11 GB (in reality 22 GB)

    I know for a fact that a newly installed windows 7 is not this huge.
    Also I selected all the folders and checked the size and it simply doesn't match what the Drive Properties tells me.
    Is there anyway to fix this?
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    MS says 64-bit W7 needs 20GB of disk space. Usually the size grows when you install all updates and stuff.
     
  3. skadd, Nov 12, 2010
    Last edited: Nov 12, 2010

    skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #3
    But my vmware fusion with W7 64bit is only 11GB +/-
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    Swap file and hibernation file. Both are sized with your RAM. The VM is probably set for 1-2 GB and you really have 4-8 GB.

    B
     
  5. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #5
    AWESOME! Thank you!

    Now I have 8 GB of used space and 24,6 GB free space. Quite the difference!

    Why would anyone need a 8+ GB pagefile anyway when you have 8 GB of RAM.
    It may have been useful a few years back, but not anymore I think.
     
  6. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #6
    on a similar note, I had the same issue. I disabled hibrenation but it keeps coming back.
     
  7. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #7
    I noticed :(

    Tried to disable hibernation in power settings and deleting the file with "powercfg -h off"
    but it keeps coming back after reboot.
     
  8. skadd thread starter macrumors regular

    Joined:
    Mar 5, 2010
    #8
    We may not be able to disable hibernation, but what we can do is make the hiberfil.sys file smaller by going into regedit: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Power

    HiberFileSizePercent = a

    This will change the size of the file to 10 percent of the ram installed.
    In my case that is 800 MB
     
  9. g-boac macrumors 6502

    Joined:
    Oct 7, 2007
    #9
    skaad, balamw:

    question - I know Mac OS and Unix well, but Windows only marginally. Can you guys elaborate on how I adjust the swap file and hibernation files - I am having the same problem as the OP, and down to about 8GB free on my 32GB partition, which is essentially a new/clean installation running only a single program (Quicken).

    thanks,
    Mark
     
  10. balamw, Nov 18, 2010
    Last edited: Nov 18, 2010

    balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #10
    Here's a link on how to tweak the pagefile. http://tweakhound.com/windows7/tweaking/7.html and from the same site a bit about hibernation http://www.tweakhound.com/windows7/tweaking/10.html. Skadd's registry hack above is a other way to reduce the size of the hibernation file.

    Like the author of the links I provided, I don't recommend messing with either the pagefile or the hibernation settings.

    May I ask why you run quicken in Boot Camp instead of a VM? Or do you plan on running other things too later? In the VM you could limit the RAM and thus the size of the pagefile and hibernation file.

    B
     
  11. karsten macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #11
    that command should work, i use it in windows all the time (old system). make sure to disable hibernation in your power saving options too you may need to do both.
     

Share This Page